Forum Forums spacedesk Discussions Incorrect IP to server from viewer with Tailscale VPN

Viewing 3 posts - 1 through 2 (of 2 total)
  • Author
  • #26806

    I am using Windows 11 and the Windows 11 viewer.

    I use Tailscale VPN to create a mesh network, but am only using Spacedesk locally between my main machine and laptop.

    The viewer correctly detects the server but is reporting the IP of another Tailscale node and not the node where the server is sitting.

    If I open the server settings, it lists the correct Tailscale IP that the server listens on and I can manually type in this IP to connect to the server from the viewer.

    This is an ok workaround but I constantly have to look up what the IP is. I have a terrible memory and always have to go to the server and check the IP.

    In the enclosed picture, you can see that the viewer reports as the IP the server exists on but this is incorrect. It is not even the local IP of the machine outwith the Tailscale network.

    The second IP is the manual connection I have to create.

    You must be logged in to view attached files.
    spacedesk Lea

    Hi @inertia,
    Maybe the wrong IP was detected first before you enabled the Tailscale VPN?
    Have you tried restarting the Windows Viewer app?
    In any case, some VPN software is known to have incompatibilities with spacedesk (e.g. discovery issues).


    The Tailscale VPN is always active, even on reboot.

    Yes, I have restarted the viewer app, I have tried quite throughly to fix the issue.

    The IP that is detected is on the server where Tailscale was first installed and configured.

    As a workaround, I have added a hostname to the viewing PCs hosts file and added the Tailscale IP.

Viewing 3 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.