Forum Forums spacedesk Discussions USB connection not working on Android device (2024)

Viewing 6 posts - 1 through 5 (of 5 total)
  • Author
  • #26509

    Laptop: DELL inspiron 16 with windows 11 24H2 (*The worst laptop in the world)
    Tablet: Samsung A9+ with Android 14 OneUI 6.0

    In device manager it would show as “USB Mobile Monitor Device”, in properties the manufacturer is “Amyuni Technologies” and this is confusing, I don’t know if spacedesk use that drive for usb display, I know that driver is for virtual display software called “USBMMID” is that conflicting with spacedesk usb driver?

    I’ve tried to update the device driver but nothing worked, spacedesk is just updated and usb connection is both enable on my laptop and tablet, I’ve tried weather usb debugging is on or off, nothing changed, I can confirm that my laptop sees the tablet but spacedesk says connected usb devide is 0, on my tablet I can’t chose USB mode since it would force it into file transfer mode when spacedesk usb mode is on.

    Any clue of why usb mode does not working? I’ve attached my diagnostic file

    *Repaired 5 time in 2 years, 4 touchpad, 1 display, 1 wireless network card, 1 keyboard(not broken but they just want replace it with touchpad)

    You must be logged in to view attached files.

    Hi @ericbig66,
    Thank you very much for sending your Diagnostic files. Unfortunately, we cannot download your zipped files. could you please use other file types such as .zip or .rar?

    For the non-working USB, please try the following:
    -disable your other virtual display software then try again if USB will work this time.
    -please try switching to File Transfer or Media Device MTP.


    plese do not use the forum as a platform to advertise, If I could I wish to kick “grewwal885” out of this forum since it is violating the rule of this forum


    Hi @ericbig66,
    Thank you very much for sending your diagnostic files.
    We already banned the spammer @grewwal885.

    Regarding your concern, it’s possible that a conflict between usb mobile monitor driver and spacedesk usb driver is causing your USB issue.

    Would you mind uninstalling the USB mobile monitor, then trying again with spaceDesk, and see if USB connection will work this time?


    I had the same problem. It only connected via LAN.
    I solved it by changing the MPT driver to MPT via USB.

Viewing 6 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.