Forum Forums spacedesk Discussions In First Connection, SpaceDesk is always the second monitor, how to change?

Viewing 4 posts - 1 through 3 (of 3 total)
  • Author
  • #26156

    My computer does not have any monitor connected to the onboard video card.
    Whenever a new device connects via SpaceDesk Viewer, it automatically displays as second monitor, which is virtual.
    I know that if you press Windows + P 3x times, the screen will be duplicated, but this can only be done using the physical keyboard, since the virtual keyboard only appears on the main monitor, which is turned off.
    After this, the screen is duplicated, and the next connections happen normally, however for new devices the process is repeated.
    My question is, is it possible for new devices to have the screen already appear duplicated?


    Hi @fmgdias,
    It appears that “Extend” mode is the default setting for new devices. This behavior is characteristic of the Windows operating system and, currently, there is no option for users to change its default settings.
    Also, Windows remembers the last setting as it saves the display configuration in its graphics database.


    I found a great solution.

    1) Enable the taskbar on all monitors.
    2) Create shortcuts for each screen mode.
    Main Display Only: C:\Windows\System32\DisplaySwitch.exe /internal
    Second Display Only: C:\Windows\System32\DisplaySwitch.exe /external
    Main & Second: C:\Windows\System32\DisplaySwitch.exe /extend
    Both Same: C:\Windows\System32\DisplaySwitch.exe /clone
    4) Change the icons for each screen mode (use the icons from the DisplaySwitch.exe itself)
    5) Pin them to the taskbar.

    You must be logged in to view attached files.

    Hi @fmgdias,
    Thank you for sharing this valuable information. This contribution will undoubtedly be beneficial to many users in the future!

Viewing 4 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.