Forum Forums spacedesk Discussions Cannot detect any primary machine

Viewing 4 posts - 1 through 3 (of 3 total)
  • Author
  • #3749

    My primary machine is an Acer Aspire PC, running on Windows 10. I have the driver installed, and have restarted my computer as well as uninstalling and re-installing the app. I’ve tried asking my computer to repair the app. I’ve also manually approved the app with my firewall. The app has been showing “ON (idle)”, but I’ve tried many times turning it off and back on, and that hasn’t changed anything. I’ve tried messing with my primary device display settings. I’ve tried playing with the Videowall Engine.
    My secondary machine is a Kindle Fire HD10 (under a year old), and I have the app downloaded from the Amazon App Store. It says “cannot detect a primary machine.” I have tried restarting the device and the app, have tried uninstalling and re-installing it. I’ve tried many times adding the primary device manually with my IP address, but it just circles and says it’s working on it forever.
    Both machines are on the same wifi, and I’ve tried moving them both to a second wifi, with no luck. I’ve tried changing both wifi networks to private. I’ve also tried using my Android Galaxy smartphone as the secondary device, but it has the exact same issues, which makes me think the problem is with my primary device.
    Can you help me? I would so love to get this working.
    Thank you in advance!

    spacedesk Lea

    Hi @mignonib,

    Looks like a network connection issue.

    Are both machines connected on the same wifi network with the same network band (2.4Ghz or 5Ghz)?

    Do you have third party firewall software?

    Do you have VPN (Virtual Private Network) active?

    Could you please check your router settings if wireless isolation is enabled?
    This settings prevents direct communication between connected machines/devices.

    For assistance, please check Troubleshooting -> Network Connection chapter in the user manual for details https://forum.spacedesk.netuser-manual/.

    Can you quickly try a WiFi Hotspot connection?
    Please check Performance Tuning -> Network Bandwidth -> Wifi Direct / Wifi Hotspot / Wifi Access Point in the user manual for details https://forum.spacedesk.netuser-manual/.


    I am having a similar issue with a direct usb cable connection betwen my kindle fire HD10 and a Lenovo Yoga Laptop.


    Hi @jahunterco,
    -Have you checked if the “USB Cable Android” is enabled in spacedesk Console?
    -Is your Android device’s USB connection type set to File Transfer or Media Device MTP?

Viewing 4 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.