Forum 论坛 spacedesk Discussions WSL2 not starting after spacedesk installation

  • 该话题包含 22个回复,12 人参与,最后由yuan 更新于 2年前
正在查看 10 个帖子:11-20 (共 22 个帖子)
  • 作者
    帖子
  • #5410
    nils
    参与者

    I have the same problem, installed Spacedesk and even after uninstalling wsl doesn’t work.
    Any update?

    #5411
    undefinedman
    参与者

    Not yet, i am trying for few days already and ran out of ideas…

    #5416
    Myron
    参与者

    Had the same problem. Not just WSL. Hyper-V breaks as well as Oracle Virtual Box. All virtualisation tools seem to be compromised by spacedesk_driver_Win_10_64_v1027_BETA.

    I was lucky I had a system restore point before I installed spacedesk_driver_Win_10_64_v1027_BETA. Simply uninstalling SpaceDesk does not fix Hyper-V and related software components.

    • 该回复由Myron 于 2年、 4月前 修正。
    #5418
    spacedesk Marcel
    管理员

    Currently it seems as if there could be a side effect with microsoft hyper-v virtualization infrastructure driver.
    It seems as if the problem could be solved by manually re-installing this driver.
    Please try the fix below and let us know if it solved the problem.
    1. Go to device manager -> Action -> add legacy hardware.
    2. Choose Option „Select hardware manual from list“ in the wizard
    3. Choose „Systemdevices“ in the list
    4. Choose „Microsoft“ in vendors
    5. Choose „microsoft hyper-v virtualization infrastructure driver“ in models
    6. Follow the wizard to finish the installation
    7. Restart the computer

    附件:
    您需要登录才能查看附件。
    #5422
    undefinedman
    参与者

    Not sure if that matters, but it still does not work after installing this driver.

    附件:
    您需要登录才能查看附件。
    #5427
    undefinedman
    参与者

    Okay, started to work!

    Simply fixing the driver did not work for me, even after reboot.

    So I turned off Windows features, rebooted. Installed the driver, turned on Windows features and started to work.

    #5431
    PreXident
    参与者

    Reinstalling Microsoft hyper-v virtualization infrastructure driver helped me. Thanks a lot, you are a lifesaver!

    • 该回复由PreXident 于 2年、 4月前 修正。
    #5433
    Aiken
    参与者

    Thanks
    this method solves my problem perfectly, thank you very much !!

    In my situation,
    – After reinstall the microsoft hyper-v virtualization infrastructure driver,
    – In the device manager list, it still shows that there is a problem with this driver,
    – Then i uninstall it in the device manager, After automatic reinstallation

    everything work well.

    #5434
    Aiken
    参与者

    Thanks
    this method solves my problem perfectly, thank you very much !!

    In my situation,
    – After reinstall the microsoft hyper-v virtualization infrastructure driver,
    – In the device manager list, it still shows that there is a problem with this driver,
    – Then i uninstall it in the device manager, After automatic reinstallation

    everything work well.

    #5435
    Myron
    参与者

    I will wait until SpaceDesk updates the software so as not to trigger this Hyper-V fault. I don’t currently have a machine I can test this workaround. I don’t know what else gets disturbed within the operating system.

    A VM I use under Oracle’s Virtual Box now constantly Blue Screens Windows 10 after I’ve I encountered the buggy SpaceDesk beta, but it’s something I can live with.

    So, for the people who have a dead Hyper-V and WSL installations, has this workaround brought it all back to life?

    • 该回复由Myron 于 2年、 4月前 修正。
正在查看 10 个帖子:11-20 (共 22 个帖子)
  • 哎呀,回复话题必需登录。