Forum 论坛 spacedesk Discussions Black Screen

正在查看 19 个帖子:1-18 (共 18 个帖子)
  • 作者
    帖子
  • #23979
    nhan
    参与者

    Spacedesk has been working well for me until about a week ago it just show up as a black screen. There has been recent updates with NVIDIA driver and I don’t know if it has anything to do with this.

    I’ve run into this issue before https://forum.spacedesk.net/forums/topic/help-black-screen-not-working-2/ but this time disabling the In-game Overlay didn’t help. I’ve attached the debug log and the diagnostics info to this post.

    • 该话题由nhan 于 9月、 2周前 修正。
    附件:
    您需要登录才能查看附件。
    #23987

    Hi @nhan,

    Thank you very much for sending your diagnostic logs.
    However, some information was not captured by the logs you sent. Could you please send your diagnostic logs again? This time, while the diagnostic is running, try to reproduce the black screen issue.

    just follow the steps below:
    – open spacedesk Driver Console -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – try to connect your viewer and reproduce the Black screen issue
    – switch Diagnostic Collection OFF
    – click Save All Information button (if a message box appears, just click No to proceed)
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

    #23998
    nhan
    参与者

    Hi Christian, I already attached a diagnostic information at the end of my original post. Here’s another one I just did.

    附件:
    您需要登录才能查看附件。
    #24001
    nhan
    参与者

    (Adding more details) For some reason I don’t see my laptop on my Android tablet anymore. I’ve reset my Firewall setting but still don’t see it.

    #24003
    nhan
    参与者

    I was able to fix the problem of not discovering Primary Machine by fixing my Firewall settings. The Black screen issue for USB Cable Android is still there.

    #24005
    nhan
    参与者

    I attached the latest diagnostic logs here.

    附件:
    您需要登录才能查看附件。
    #24007

    Hi @nhan,

    Thank you very much for sending your diagnostic logs.
    Are you using USB Hub or you are plugging it directly into your Machine’s USB Port?

    Could you please try the following:
    -Uninstall your spacedesk driver > then reboot your machine > install it again.
    -Restart your Android device.
    -Try a different USB cable / plug your cable into a different USB port.
    -If the issue still persists, please go to Device Manager, locate your Android device, and check for any errors (indicated by a yellow exclamation mark). If you see one, right-click on it > select ‘Properties,’ > go to the ‘General’ tab > take a screenshot > send it to us.

    #24008
    nhan
    参与者

    Hi, I’ve tried all the steps you said but it didn’t work.

    Could you tell me how I can locate my Android device in Device Manager? I didn’t see anything with a yellow exclamation mark next to it.

    附件:
    您需要登录才能查看附件。
    #24012
    nhan
    参与者

    Okay I’m not sure what happened but eventually it was fixed:

    – I’m still tinkering with it, reinstalling spacedesk on my Android tablet and it became even worse: Even when there is no USB cable plugged in, after opening the app, it flashes through the home screen and then turn into a black screen.
    – I went to apkmirror, redownloaded the previous version, still has the same bug.
    – I switched off all 3 toggles in the spacedesk Driver Console in my Windows PC (the big green toggle, the “Local Area Network” and the “USB Cable Android” checkboxes), and after switching them on again it’s fixed and worked as normally.
    – I uninstalled the old version, and reinstalled the latest version via Google Play Store and it’s working as expected.
    – Additional information: I’ve uninstalled and reinstalled the latest version of the app multiple times before but it didn’t help. 

    I hope there is an easier way to log the bug to improve user experience. I still don’t know what was wrong with my setup. It was working fine, and then there’s a bug, and suddenly it’s working fine again.

    Thank y’all for such a great app!

    • 该回复由nhan 于 9月、 2周前 修正。
    • 该回复由nhan 于 9月、 2周前 修正。
    #24015

    Hi @nhan,

    We are glad to hear that it is now working on your end. As for the other issue you’ve mentioned, we will continue investigating it on our side. If you encounter that issue again or have any questions, please feel free to let us know by creating a new thread.

    #24021
    nhan
    参与者

    The black screen issue is back again 🙁 I’ll wait for the next driver update and an update to the app on Google Play to try again then.

    #24043

    Hi @nhan,

    Have you tried toggling off all three switches, including the Android Control as you did previously?
    Could you please check if there are any errors in your Device Manager now?
    please go to Device Manager, locate your Android device, and check for any errors (indicated by a yellow exclamation mark). If you see one, right-click on it > select ‘Properties,’ > go to the ‘General’ tab > take a screenshot > send it to us.

    #24773
    Ibrahim Habibeh
    参与者

    If you go to Bluetooth and other devices in the Windows settings, find “Spacedesk Composite Device,” remove it, and reconnect the cable between your displays, then it should work.

    This issue happened to me because I was updating spacedesk while my secondary device was plugged in. My assumption is that the only device that was actually disconnected was the virtual Graphics Adapter and the composite device remained active during the driver update. So when the update finished, I believe spacedesk didn’t recognize that the Composite Device was its own device and didn’t start the graphics adapter because of that.

    #26682
    Dmitriy_31223
    参与者

    I have the same problem, but it doesn’t go away

    #26686

    Hi @dmitriy_31223,
    Do you have both latest spacedesk Driver and viewer?
    What secondary machine are you using? (Android/iOS/Windows)?
    What connection type? (Wifi/USB)?
    Have you tried all of our suggestions on our previous replies?

    #26691
    Dmitriy_31223
    参与者

    The application version is the same. Downloaded on Android. Tried to connect via usb and wi-fi. Yes, I used the previous tips. I have already downloaded it 20 times. If I turn off my PC and then turn it on, then after turning it on, the picture appears, but before the first application that turns on. Then I can no longer do nothing.

    #26692
    Dmitriy_31223
    参与者

    I get a monitor, but on the tablet it’s black

    #26693
    Dmitriy_31223
    参与者

    PHOTO

    附件:
    您需要登录才能查看附件。
    #26696

    Hi @dmitriy_31223,
    Could you please try to switch off your Videowall settings?

正在查看 19 个帖子:1-18 (共 18 个帖子)
  • 哎呀,回复话题必需登录。