Forum 论坛 spacedesk Discussions Apple Mobile Device Service/Process

正在查看 13 个帖子:1-12 (共 12 个帖子)
  • 作者
  • #25721

    Hi, thanks for your great app. I’m using it for months and have best experience.
    recently apple released an app called “Apple Devices” on Microsoft store for windows 11 and now iTunes is out of support. I think it’s a migration from old iTunes. but after installing apple devices app from win store the Apple Mobile Device Service/Process will not be available and it’s not installed anymore. apple uses windows update to install latest apple drivers. SpaceDesk uses Apple Mobile Device Service/Process to share screen through cable. how can I solve this issue and have AMDS without installing iTunes on windows?

    Error: “Apple Mobile Device Service/Process is not running. Please download and install iTunes.”


    Hi @s-h-e-i-k-h,
    Thank you very much for reporting this problem.
    We were able to reproduce this issue and currently working on resolving the issue. We will inform you once the fix is ready for download.
    For now, please download the iTunes from their website, we have checked and the service from iTunes website is still working.


    Tried SpaceDesk without iTunes, although had the previous error with cable, but everything was ok and I’m mirroring my windows screen on my iPad as always everything is fine.
    thanks for the support <3


    Hi @s-h-e-i-k-h,
    We just released a new spacedesk Driver v2112 on the web.
    this update includes the fix for Apple Mobile Device process issue <--(Itunes downloaded from app store). Please try it and let us know if it is now working for you. We look forward to your feedback!


    Hi, I just installed the v2.1.12 and still have the error but everything is fine, I can connect with cable to apple devices with no problem. So uninstalled and reinstalled the v2.1.12 again but problem still persists.

    “Apple Mobile Device Service/Process is not running.
    Please download and install iTunes.”


    Hi @s-h-e-i-k-h,
    based on your previous replies, you said you uninstalled Itunes.
    have you reinstalled it before trying the new version?

    if you previously downloaded Itunes from their website, could you please uninstall it together with apple mobile device support. you can uninstall them in Control Panel > programs > uninstall a program -> then proceed to install Itunes from App store -> try the latest version


    Hi, due to some problems with my previous windows, I clean-installed windows 11 23H2 version and then installed apple devices app from microsoft store (so there is no effects of iTunes on my windows). Then tried connecting my iPad to my pc and after windows auto-driver installation (windows updates) and some restarts, checked iPad connection with windows and everything was good. After that, downloaded and installed v.2.1.12 but still have previous problem with the “Apple Mobile Device Service/Process is not running. Please download and install iTunes.” message.
    Today morning, tried to connect with USB again and client version of spacedesk on iPad could not recognize USB connection. So I turned off and on the “USB Cable iOS” option in spacedesk server app on windows, then I had the pop up on iPad and everything was fine.
    So I think the bug still persist =D
    I also have an other issue on every versions from old to new one.
    I’ve set windows (power plan) “turn off screen time out” on 3 minutes and “sleep timeout” on “never”.
    After 3 minutes, my laptop screen goes black; but it’s still working. On my iPad I receive a message that says “connected – screen off” and the message is permanent until I move my mouse so my laptop screen is turned on again. I think in future I will have the burn-in problem on my iPad screen (the burn-in issue is a common problem in LCDs and you will see a shadow of some permanent elements of UI e.g. battery icon on status bar even you change the background). please add an option to the client spacedesk app to turn off this message, so it will be only a blank screen on second display and it will be healthier for LCDs and AMOLED displays.
    thanks a lot for your excellent support.


    Hi @s-h-e-i-k-h,
    For clarification, after you clean install your windows, you only installed the Apple devices app from Microsoft store and not iTunes, is that right?

    If your iTunes app is from the Microsoft Store, you must still open it for Spacedesk Console to detect it.

    For your concern about the burn-in, we already forwarded this to our iOS developer. we will let you know once there is an update about this issue.


    Hi there –<-@ (that’s a flower =D )
    yes you’re right. only apple devices.

    ** iTunes is out dated and apple will not update and support the iTunes app in future.

    thanks for forwarding my message.


    Hi @s-h-e-i-k-h,
    I see, that could be the reason why your spacedesk Console is still displaying that error message.
    Are you unable to install iTunes from the MS Store? if not,
    Could you please try installing iTunes from the MS Store -> Run the iTunes app -> check your USB Cable iOS if it still displaying the message?

    Also, please make sure to update your spacedek Driver to v2.1.13


    Hi @s-h-e-i-k-h,
    We have released a new spacedesk Driver v2114 on the web.
    This update includes the detection of Apple Devices app, Please update your driver to the latest version and see if it works for you.
    make sure your Apple Devices app is running in the background.
    looking forward to your feedback!


    the problem solved with v.2114 update. thanks <3


    Hi @s-h-e-i-k-h,
    We are glad to hear that spacedesk is working now on your side.
    We will now close this issue. In case you encounter any spacedesk issue don’t hesitate to contact us.

正在查看 13 个帖子:1-12 (共 12 个帖子)
  • 话题“Apple Mobile Device Service/Process”已关闭,不接受新回复。