Forum 討論群 spacedesk Discussions Need help connecting via USB

正在檢視 6 篇文章 - 1 至 5 (共計 5 篇)
  • 作者
  • #6454

    Hi, I seem to have a spot of bother. I wanted to use my tablet as a second monitor using your software via USB/USB tethering (because of lag). But the app sometimes works sometimes it doesn’t. Have also tried connection through laptop hotspot, it did work but then stopped working too. When I connect the tablet to the laptop’s hotspot it says: Connected no internet. Tried other apps but yours is better. If you could help me fix it that would be great. I know Spacedesk does not natively support connection via USB, but I see you mentioned about abd port forwarding. But to be fare I don’t really know how to do it. Could you please help me. Laptop (primary machine) Dell latitude 7490 running Windows 10. Tablet (secondary machine) Lenovo tab m10 FHD plus running Android 10. Many Thanks

    spacedesk Lea

    Hi @matt,
    Can you further describe when you said USB tethering sometimes doesn’t work?
    Is the private network cannot establish over USB tethering?
    You can easily check in the spacedesk Driver Console -> Network -> Adapter Interface, if the Remote NDIS Adapter is active (this is the network adapter for USB tethering network).

    As for the “Connected no internet” in hotspot setup, this is still good since spacedesk does not require internet connection, it only needs to be connected to a local area network.

    In case you want to try the Android Debug Bridge Cable connection, just follow the steps below:
    1. Connect your android device via USB and enable the USB debugging in the Developer options on your Android System settings.
    2. Download Android SDK platform tools on your primary machine, then extract it.
    3. Open command prompt on the primary machine, change the directory to your android SDK platform tools folder, then type the command: adb.exe reverse tcp:28252 tcp:28252
    4. On your Android device, open the spacedesk Viewer app, and make sure to disable the auto-discovery by unchecking the LAN/WiFi box below.
    5. Click the + button, then try to connect to IP address.


    Good morning @lea, when I connect the tablet to laptop via USB tethering, in the Spacedesk Driver Console it shows the Remote NDIS Adapter, but the viewer app does not detect it. I seen you mentioned something similar in the past but I didn’t know you can use Spacedesk over laptop hotspot that says: Connected no internet. Will try that. I just tried the connection over ADB cable and… IT WORKD!!! Many thanks Lea. Now everything works again 🙂

    • 該回覆由 Matt 於 2 years, 5 months ago 修改。

    You forgot to mention but adb reverse only works on android 5.0+, tried that on my android 4.2.2 device and lost i my time


    Oh @aragubas, I didn’t know that. Though my tablets are running Android 10, so that wasn’t a problem for me. Thanks

    spacedesk Lea

    Hi @aragubas,
    We are not aware of this requirement. Thank you very much for the info.
    We will add this additional info in our documentation.

正在檢視 6 篇文章 - 1 至 5 (共計 5 篇)
  • 主題「Need help connecting via USB」 已關閉,不允許發佈新回覆。