Forum 討論群 spacedesk Discussions Enable touch as pointer clicks instead of touch events

正在檢視 4 篇文章 - 1 至 3 (共計 3 篇)
  • 作者
  • #1823

    While trying to use Spacedesk for Microsoft Flight Simulator, like many others I’ve come to the realization that the simulator does not support touch inputs properly.

    However, I found an old topic in the old Spacedesk support forum which explained how to fall back from touch input to mouse input in Spacedesk, which seems to have solved the issue. Unfortunately, the instructions there were for an older version, and seem to no longer be valid. Is it still possible to switch back to use mouse pointer input?

    The instructions I’m referring to (relevant for v0969):

    You can still use the mouse touch input (like before) just follow the steps below:
    – run services.msc on your primary machine
    – find spacedeskService and right-click Stop it (temporarily)
    – run devmgmt.msc on your primary machine
    – click “View” tab “Device by connection”
    – find spacedesk virtual HID Device (Can no longer find this in newer versions)
    – underneath the spacedesk virtual HID Device, right-click “disable device” all 3 HID-compliant touch screen
    – go back to services.msc and restart the spacedeskService
    – try to connect a spacedesk viewer, mouse-touch input should work now instead of touch screen input

    • Server: Win 10 / Spacedesk 1.0.9
    • Client: Amazon Fire Tablet / Spacedesk 0.9.74

    (aka msfs msfs2020 – leaving this here for future google searchers)

    spacedesk Lea

    Hi @digitalmechanic,
    Ah yes, with the latest spacedesk driver it’s a bit different now.
    First, FYI the current spacedesk Driver now supports actual touchscreen input for the first viewer app only, and if you connect another viewer app it will fall back in using the old mouse touch input that you want to use.

    This is the new workaround if you still want to use the mouse touch input instead of actual touch screen input.
    – connect your viewer app first
    – open the device manager then click “View” tab “Device by connection”
    – go to spacedesk Virtual Bus and expand it
    – initially you will find spacedesk Mouse and spacedesk virtual HID Device (HID Keyboard Device)
    – try to send a touch input from your viewer app and you will find another spacedesk virtual HID Device with HID-compliant touch screen underneath
    – Just right-click disable both spacedesk virtual HID Device and HID-compliant touch screen underneath it
    Then you will notice on your next touch input it will now use the mouse touch input.


    It worked! You just made my day!

    I have to say, I’ve seen many paid apps (and expensive ones) with support far worse than yours. Kudos to you!

    My only suggestion is that this should really be a settings option, rather than this sort of hack.

    spacedesk Lea

    Hi @digitalmechanic,
    we are glad that it worked on your side.
    Thanks for the suggestion, we will take note of it.

正在檢視 4 篇文章 - 1 至 3 (共計 3 篇)
  • 主題「Enable touch as pointer clicks instead of touch events」 已關閉,不允許發佈新回覆。