Forum 討論群 spacedesk Discussions Black screen on android device with USB connection

正在檢視 9 篇文章 - 1 至 8 (共計 8 篇)
  • 作者
  • #25299

    Hi! I have been having the same issue.
    It started when I connected the tablet through the USB chord. After that, it always blinks on the main page for a moment, just like a human life before the vastness of the Cosmos, and goes to the black screen. I have already uninstalled and reinstalled the Android and the Windows apps, revoked all USB permissions on the Android, unchecked the USB Cable Android option… Everything I could think of.
    Yet the black screen continues to haunt me as a reminder of the empty abyss of death waiting for us all.


    Hi @ladeira42,
    to clarify, even without USB cable, and Native Android USB option Disabled, it always goes to blackscreen automatically. is that correct?

    if so, in case the “Android USB Cable” is already enabled in spacedesk Driver Console..
    and you want to connect spacedesk via USB cable, please try the following:
    – switch OFF the “Android USB cable” in spacedesk Driver Console
    – plug USB phone cable to your primary machine and open the spacedesk viewer app (viewer settings will be accessible in this case)
    – switch ON the “Android USB cable” in spacedesk Driver Console

    If you want to connect spacedesk via WiFi, you have to switch OFF the “Android USB Cable” in spacedesk Driver Console and/or unplug the USB cable of your android phone.

    if this doesn’t work, could you please try rebooting your device? We have received old feedback from similar cases indicating that rebooting their device fixes the problem.


    Hi @ladeira42,
    just a follow-up question.
    Are you still experiencing this issue? if yes, could you please check if your Android Developer Mode is Enabled in your device settings?


    Hi, I’m having this issue as well.
    The Driver Console on windows was showing me a message saying that i had to update my drivers, meanwhile on my phone (connected via USB Cable android) the screen was on a greyscale, there were no colors.
    Later I updated the Driver Console and Android app and when I connected the USB cable to my phone, all I see is a black screen where there is not much to do.
    I’ve already tried rebooting PC and phone, but the black screen is a constant. LAN connection does work btw, but the lag is somewhat important (probably because of my wifi).


    Hi @matias04,

    Can you tell us what Android device you are using?
    Have you tried the suggestions above? Could you please try to enable USB DEBUGGING in your developer options and see if it will work?

    If not, please send us the Diagnostic logs of this Issue.
    Just follow the steps below:
    – open spacedesk Driver Console -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – reproduce the blackscreen issue using USB connection.
    – switch Diagnostic Collection OFF
    – click Save All Information button (if a message box appears, just click No to proceed)
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.


    I’m using a Samsung S23 Ultra, and yes, I have the USB Debugging on in the developer options, already tried turning it off and on, but still nothing.
    PS: thank you very much for your fast response, I appreciate it.

    你必須 登入 才能查看附件檔案。

    Hi @matias04,
    Thank you very much for sending the required files. Unfortunately, we haven’t found any traces that can help us with the issue.
    Did you make sure to reproduce the issue while the Diagnostics option is enabled in the console?
    Can you please try to collect again and make sure to strictly follow the steps provided in my last reply?
    Looking forward to your feedback.


    Everything was done following the steps you provided before. Now, when the black screen appears, i can see the message box about the free license for non comercial use only. If i try to disconnect from my phone using the floating toolbox, the app just stops working.

    你必須 登入 才能查看附件檔案。

    Hi @matias04,
    Thank you very much for sending your Diagnostic logs.
    based on the logs, the server did not recognize your device upon plugging in.
    Have you tried turning your spacedesk Server and USB Cable Android option Off-On?
    Could you also please try rebooting your Android device?

正在檢視 9 篇文章 - 1 至 8 (共計 8 篇)
  • 抱歉,回覆主題必需先登入。