Forum Forums spacedesk Discussions WSL2 not starting after spacedesk installation

Viewing 23 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #5246
    tono
    Participant

    I’m facing the same problem in this link.
    https://github.com/microsoft/WSL/issues/4930

    It seems spacedesk causes the problem.
    The problem occurred just after I installed spacedesk.
    I uninstalled spacedesk but it didn’t resolve the issue.

    I appreciate if anyone knows resolution.

    Thanks.

    #5280
    Aiken
    Participant

    My friend and I also encountered this problem. After installing spacedesk, WSL2 could not start. We tried all the methods in the corresponding link but could not solve this problem.

    Even if it is uninstalled, the system cannot be restored to its original state. I really hope you can locate the problem and give a solution.

    Thanks.

    • This reply was modified 2 years, 6 months ago by Aiken.
    #5307
    spacedesk Lea
    Keymaster

    Thank you very much for the feedback.
    We will investigate and try to reproduce this issue.
    We will get back to you as soon as we have analyzed it.

    #5358
    l3xx3r
    Participant

    Same problem here.
    Tried the usual fixes, like disable hyper-v, platform and wsl. Restart and renable, also doesn’t fix the problem.
    Uninstalling spacedesk does not fix the problem.

    Just let me know if you need further information about the enviroment.

    Greetings

    • This reply was modified 2 years, 6 months ago by l3xx3r.
    #5360
    spacedesk Lea
    Keymaster

    Hello everyone,

    For further analysis, could you please send us the diagnostic logs.

    If you still have spacedesk installed on your machine, just click the spacedesk tray icon to open the spacedesk Driver Console, then go to Diagnostics page and click the “Save All Information”.
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.

    If you already have uninstalled/removed spacedesk on your machine, then please send us the following logs:
    – dxdiag file (run dxdiag.exe then click “Save All Information”)
    – C:\Windows\INF\setupapi.dev.log

    Save all files in one folder then, right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file on your next reply.

    #5377
    l3xx3r
    Participant

    Hello again,

    i’ve attached the logs. I also tried to reset via windows system restore(could help some people), in my case the restore wasn’t successfull at all.

    greetings
    alex

    Attachments:
    You must be logged in to view attached files.
    #5379
    undefinedman
    Participant

    For me spacedesk also crashed wsl2 and even after uninstalling spacedesk, i cannot start the wsl (tried turning on/off in Windows features) throwing an error “Please enable the Virtual Machine Platform Windows feature and ensure virtualization is enabled in the BIOS.
    For information please visit https://aka.ms/wsl2-install”

    #5380
    bananacry
    Participant

    I fixed the issue through a Windows Update Installation (keep personal data) and didnt reinstalled spacedesk after it.

    One additional informaton. Windows Sandbox also gets broken, and also got fixed by the update installation.

    #5381
    darkan35
    Participant

    Hello,

    I wait a solution, because since the spacedesk problem, I can no longer work.
    And solution to pass by windows update and reinstall system is not solution for me.

    #5384
    darkan35
    Participant

    I found this.
    Wsl is not started because Hyper V service is not started and I can’t started manually this.
    I Try to install an old version but Wsl don’t start.

    #5410
    nils
    Participant

    I have the same problem, installed Spacedesk and even after uninstalling wsl doesn’t work.
    Any update?

    #5411
    undefinedman
    Participant

    Not yet, i am trying for few days already and ran out of ideas…

    #5416
    Myron
    Participant

    Had the same problem. Not just WSL. Hyper-V breaks as well as Oracle Virtual Box. All virtualisation tools seem to be compromised by spacedesk_driver_Win_10_64_v1027_BETA.

    I was lucky I had a system restore point before I installed spacedesk_driver_Win_10_64_v1027_BETA. Simply uninstalling SpaceDesk does not fix Hyper-V and related software components.

    • This reply was modified 2 years, 6 months ago by Myron.
    #5418
    spacedesk Marcel
    Keymaster

    Currently it seems as if there could be a side effect with microsoft hyper-v virtualization infrastructure driver.
    It seems as if the problem could be solved by manually re-installing this driver.
    Please try the fix below and let us know if it solved the problem.
    1. Go to device manager -> Action -> add legacy hardware.
    2. Choose Option „Select hardware manual from list“ in the wizard
    3. Choose „Systemdevices“ in the list
    4. Choose „Microsoft“ in vendors
    5. Choose „microsoft hyper-v virtualization infrastructure driver“ in models
    6. Follow the wizard to finish the installation
    7. Restart the computer

    Attachments:
    You must be logged in to view attached files.
    #5422
    undefinedman
    Participant

    Not sure if that matters, but it still does not work after installing this driver.

    Attachments:
    You must be logged in to view attached files.
    #5427
    undefinedman
    Participant

    Okay, started to work!

    Simply fixing the driver did not work for me, even after reboot.

    So I turned off Windows features, rebooted. Installed the driver, turned on Windows features and started to work.

    #5431
    PreXident
    Participant

    Reinstalling Microsoft hyper-v virtualization infrastructure driver helped me. Thanks a lot, you are a lifesaver!

    • This reply was modified 2 years, 6 months ago by PreXident.
    #5433
    Aiken
    Participant

    Thanks
    this method solves my problem perfectly, thank you very much !!

    In my situation,
    – After reinstall the microsoft hyper-v virtualization infrastructure driver,
    – In the device manager list, it still shows that there is a problem with this driver,
    – Then i uninstall it in the device manager, After automatic reinstallation

    everything work well.

    #5434
    Aiken
    Participant

    Thanks
    this method solves my problem perfectly, thank you very much !!

    In my situation,
    – After reinstall the microsoft hyper-v virtualization infrastructure driver,
    – In the device manager list, it still shows that there is a problem with this driver,
    – Then i uninstall it in the device manager, After automatic reinstallation

    everything work well.

    #5435
    Myron
    Participant

    I will wait until SpaceDesk updates the software so as not to trigger this Hyper-V fault. I don’t currently have a machine I can test this workaround. I don’t know what else gets disturbed within the operating system.

    A VM I use under Oracle’s Virtual Box now constantly Blue Screens Windows 10 after I’ve I encountered the buggy SpaceDesk beta, but it’s something I can live with.

    So, for the people who have a dead Hyper-V and WSL installations, has this workaround brought it all back to life?

    • This reply was modified 2 years, 6 months ago by Myron.
    #5447
    tono
    Participant

    Re-installing the driver resolved the issue.
    Thank you so much.

    #5476
    Myron
    Participant

    Installed beta RC v1.0.29 and all is well again. Thank-you. 🙂

    #7794
    yuan
    Participant

    I never thought that space-desk causes this wsl bug. I checked all the information I could find on Internet, but it worked until I saw this.
    To express my appreciation, I register an account and write these words.
    Thank you, guys!! Repairing Hyper-V drivers helps my life!!!

    And remember, if you want to use wsl2, preparing virtualisation drivers is necessary when you ensure you have enabled all the virtualisation features.

Viewing 23 posts - 1 through 22 (of 22 total)
  • You must be logged in to reply to this topic.