Forum Forums spacedesk Discussions USB Tethering Lag – Fire HD 8

Viewing 14 posts - 1 through 14 (of 15 total)
  • Author
    Posts
  • #25083
    JigglyPug
    Participant

    Streaming over Wi-Fi my Fire HD Tablet has no issues with lag, I am able to maintain full settings for RGB bit depth, image quality and 60fps. However, when connected through USB tethering the connection will completely freeze on the tablet after about 15 seconds. I have tried every post in this forum that mentions the word USB.

    I have enabled/disabled USB tethering, change the USB preference from nothing to file transfer, I have tried multiple cables both USB C to USB C and USB C to USB A. Connection is flawless over Wi-Fi. Changing quality settings has no effect. It always lags and freezes about 10-15 seconds into the connection. The first few seconds are fine.

    Does the fire line of tablets need some sort of ABD command or USB driver installed on the PC?

    #25084

    Hi @jigglypug,
    Please try connecting via native Android USB cable instead of USB tethering.

    You can refer to Direct USB Cable Connection chapter in the user manual – https://forum.spacedesk.netuser-manual/#item_11715

    #25087
    JigglyPug
    Participant

    I have tried direct USB as well but there is now difference. It is about 1 frame per 10 seconds.

    #25092

    -Could you please check if your spacedesk Android viewer app and spacedesk Windows Driver is updated to the latest version? if not, please update it.
    -if they are already updated to the latest versions, maybe reinstalling them could help.
    -can you also try to plug you cable to different ports?

    #25093
    JigglyPug
    Participant

    Both are updated to the latest version as I just installed yesterday, performed a manual check as well. I have reinstalled and tried every available port on my machine.

    #25094

    Hi @jigglypug,
    Thank you for trying the above suggestions.
    for further investigation, could you please send us the Diagnostic logs of this Issue?
    Just follow the steps below:
    – open spacedesk Driver Console -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – reproduce the issue using USB connection.
    – switch Diagnostic Collection OFF
    – click Save All Information button (if a message box appears, just click No to proceed)
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

    #25095
    JigglyPug
    Participant

    It appears it is too big for file upload; I will break it into 2 parts and upload separately.

    • This reply was modified 2 months ago by JigglyPug.
    #25097
    JigglyPug
    Participant

    Needed to readjust my upload as the max file size is only 512KB.

    • This reply was modified 2 months ago by JigglyPug.
    Attachments:
    You must be logged in to view attached files.
    #25099
    JigglyPug
    Participant

    Needed to readjust my upload as the max file size is only 512KB.

    #25101
    JigglyPug
    Participant

    Finally, was able to distribute them equally enough to pass the upload requirement. Sorry for the hassle.

    Attachments:
    You must be logged in to view attached files.
    #25104

    Hi @jigglypug,

    Just to clarify, is this your settings on spacedesk Android viewer?
    Image quality: 100
    yuv 444
    60 fps
    RGB 888

    Also, could you tell us if there’s a difference in performance if you change or lower the quality and bit depth settings?

    #25105
    JigglyPug
    Participant

    I turned down the quality to 50% as well as the color profile to low and the RGB to 16bit. However the issue is still present. It is normal for around 5-10 seconds and then lags to about one frame refresh every 10 seconds or so.

    #25108

    Hi @jigglypug,
    Thanks for the information, we already forwarded this to our Android developer. We will update you once a progress has been made.

    #25110
    JigglyPug
    Participant

    Thanks so much. I will continue using the Wi-Fi mode for now which doesn’t have the problem.

Viewing 14 posts - 1 through 14 (of 15 total)
  • You must be logged in to reply to this topic.