Forum Forums spacedesk Discussions USB Device Not Recognized

Viewing 4 posts - 1 through 3 (of 3 total)
  • Author
  • #25694

    Receiving “USB Device Not Recognized” error while trying to setup devices. Tried it on two different Android devices. Also tried rebooting all devices and slowly inserting USB as suggested. Noticed now in Device Manager that the device driver name reads “Android Accessory Interface” with a warning symbol. It was previously “spacedust ________” (still didn’t work in the last version). The actual description for the error reads:

    “This device cannot start. (Code 10)

    The USB device returned an invalid Microsoft OS extended configuration descriptor.”


    Hi @bandwagoner,
    Could you please try plugging the cable using the other USB ports?
    if the issue persists, maybe try to uninstall spacedesk -> plug USB cable -> then check if the issue will still happen.


    USB connection works perfectly fine if I turn off Android USB mode in Spacedesk. I’ve tried re-installing Spacedesk on both Windows and Android devices (Pixel 7 and Lenovo tablet) with no success.


    Hi @bandwagoner,
    I see, could you Please send us the Diagnostic logs of this Issue.
    Just follow the steps below:
    – open spacedesk Driver Console -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – please reproduce the issue
    – switch Diagnostic Collection OFF
    – click Save All Information button (if a message box appears, just click No to proceed)
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

Viewing 4 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.