Forum Forums spacedesk Discussions USB connected but data transfers through WIFI

Viewing 11 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #19231
    rfxcasey
    Participant

    So how exactly does the USB connection work? I have it enabled but Spacedesk still seems to be streaming the screen data over WIFI. When I connect to a slower WIFI network I’ll get more lag then when connected to a faster WIFI network, but why is this the case when the data should be transferring through the USB cable?

    #19235

    Hi @rfxcasey,

    To ensure that you are connected via USB, you can temporarily turn off the Wi-Fi network on either your secondary or primary machine, then proceed to test the connection.

    For further assistance about connecting via USB cable, you can refer to the chapter “CONNECTING A NEW DISPLAY MONITOR OVER THE USB CABLE” in the user manual
    https://manual.spacedesk.net/CONNECTINGANEWDISPLAYMONITOROVE1.html

    #19298
    rfxcasey
    Participant

    So you’re saying the displays should still work if I turn off wifi on the tables? If I turn off the wifi Spacedesk on my main machine won’t find the tablets.

    • This reply was modified 7 months, 2 weeks ago by rfxcasey.
    #19300
    rfxcasey
    Participant

    All software in installed and up to date on the primary and secondary devices. Still app on tablets can’t find the primary machine.

    #19301

    Hi @rfxcasey,

    Is your tablet an Android device?
    Even if you turn off Wi-Fi on both your tablet and main machine, the display should still work as long as you are connected via a USB connection.

    To guarantee your USB connection is established, you can follow the steps below:

    -Turn off Wi-Fi on both your tablet and main machine.
    -Make sure you enable “Android USB Cable” in the Spacedesk Driver Console under communication interfaces.
    -Plug your tablet into your main machine using a USB cable.
    -Check your tablet for a Spacedesk prompt and click “Allow” or “Yes”.
    -You should now be able to connect with Spacedesk using a USB connection.

    Looking forward to your feedback.

    #19314
    Riyan Permana
    Participant

    Maybe his tablet isn’t support USB OTG connection. Well i think that’s what i can assume. Because whenever i connect othe device to my android phone i.e arduino the pop-up show “allow arduino to use usb..blablabla” similar to spacedesk.

    #24500
    rfxcasey
    Participant

    Sorry for the VERY late reply, but I’m still having this issue. I’m using Amazon Fire Tablets which are Android devices. I’m wondering if there is some ‘USB debugging’ or USB connection setting that needs to be adjusted. As on my phone, when I connect it to a PC via USB cable, I have to go to the USB settings and authorize the connection each time before I can copy pictures straight from my phone. After the authorization my phone shows up as essentially another drive.

    • This reply was modified 3 months, 2 weeks ago by rfxcasey.
    • This reply was modified 3 months, 2 weeks ago by rfxcasey.
    • This reply was modified 3 months, 2 weeks ago by rfxcasey.
    #24504

    Hi @rfxcasey,

    So, your issue is still spacedesk streaming data over WiFi even if the USB cable is connected and USB cable android is enabled in the console.

    Questions:
    -When you plugged in the Android USB cable, did you see the ‘spacedesk Android USB Device’ in Device Manager under ‘Universal Serial Bus devices’? Or did it show the default name of your Android Tablet’s USB device?
    -Upon plugging your Android device cable, did you see any pop up on your phone that say something like “open spacedesk to handle USB?”
    -Are you plugging your USB Android cable directly into your primary machine’s USB port? Or are you perhaps using a USB hub?

    Could you please try the following:
    -Reinstall and update your spacedesk Android viewer app and spacedesk Windows driver to the latest version.
    -Try using other USB cables/USB ports.
    -Please check if ‘USB debugging’ is enabled in the Developer options of your phone. If it is enabled, please disable it and try again with the spacedesk USB connection.
    -Within the Developer options, find ‘Default USB Configuration,’ then select ‘File transfer.’ This will enable you to set your device to always be on file transfer mode as default.

    #24505
    rfxcasey
    Participant

    Thanks for the reply. I figured out how to set my Fire tablets to ‘USB debugging’ mode, question now is, what do I set for the USB default? I have several options, ‘file transfer’, ‘MIDI’, ‘PTP’ and ‘No data transfer’. I’ll experiment and see if I can figure it out.

    #24506
    rfxcasey
    Participant

    What protocol does Spacedesk use over USB, ‘File transfer’ or ‘PTP’?

    #24511

    Hi @rfxcasey,

    Spacedesk primarily uses the Android Open Accessory Protocol over USB – in this case, you should select ‘File transfer’.
    BTW: have you tried the suggestions above? please note that we have cases that in some devices ‘USB debugging’ prevent spacedesk USB connection from working. so it’s better to keep USB debugging disabled.

Viewing 11 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.