Forum Forums spacedesk Discussions USB Cable driver This device cannot start. (Code 10) Lenovo P11 Pro Gen 2

Viewing 8 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #26063
    Dweaver
    Participant

    I am using a Lenovo P11 Pro Gen 2 tablet running Android 13 and while Wifi works, I would like to use the USB cable option to reduce reliance on Wifi and network connectivity to use the tablet as a monitor plus I feel it would be more secure if I disabled the LAN.

    I am getting an error the device can not start Code 10. I have tried 5 different cables including the one that came with the tablet, they all fail the same. I have also tried setting the tablet to default to Tethers and File Transfer, tethered seem to hide the device so the driver does nothing, File Transfer is when I get the error.

    USB is not in debug mode on the tablet.

    I have attached a copy the diagnostics I captured from the space driver console.

    #26064
    Dweaver
    Participant

    I accidentally uploaded the wrong file, here is the debug log.

    #26065
    Dweaver
    Participant

    3rd time the charm? :-). Here is the log as a zip.

    Attachments:
    You must be logged in to view attached files.
    #26070
    spacedesk Nicole
    Keymaster

    Hi @dweaver,

    could you please send the full spacedesk diagnostics?

    Is the cable directly connected to a USB port or hub?
    Is the cable connected to a USB 2.0 or 3.0 port?
    Have you tried to slowly unplug-plug the USB cable?
    Have you tried to restart the tablet and Windows PC?

    #26072
    Dweaver
    Participant

    I have tried direct to laptop and through a dock I also tried slow plug. On the laptop it’s USB-C so assume 3.0 I have tried several different ports on 2 different docks so a mix of USB 2 and 3.

    Is the zip I attached not the diagnostics?

    #26073
    tm_beetle
    Participant

    I am experiencing the same problem as him.
    I am trying to extend the screen on my surface laptop and fire hd 8.
    I have succeeded with wireless but failed with wired connection.
    I will describe what I have tried to improve the situation.
    The USB surface laptop has USB type-A 2.0 and mini displayport and the fire hd 8 has USB type-c.
    First, I tried to connect both devices USB to USB.
    Both devices made a connection sound, but the screen did not extend.
    The USB connection was not recognized on spacedesk either.
    Next, we tried connecting via mini displayport.
    When connecting the cable, we used a capture board so that the direction of the output was in one direction, but the screen was not output.
    However, other applications were able to make a wired connection this way.

    In addition, we restarted and reinstalled the app, unplugged and plugged in the cable, and restarted the device, but could not do so.

    I would also like to use it without wi-fi.
    Thank you in advance for your help.

    #26076
    spacedesk Nicole
    Keymaster

    Hi @dweaver,

    the file you sent is only a part of the diagnostics.
    The diagnostics should create a folder with name [date]-spacedeskRuntimeDiagnostics.

    Which device has the Code 10 error?
    – spacedesk Android Control device?
    – spacedesk Android USB Device?
    – Lenovo MTP device?

    Have you tried with USB Type A on the laptop?

    #26077
    spacedesk Nicole
    Keymaster

    Hi @tm_beetle,

    which device has the Code 10 error?
    – spacedesk Android Control device?
    – spacedesk Android USB Device?
    – Fire HD MTP device?

    Is the tablet’s USB connection type set to File Transfer or Media Device MTP?
    USB debugging off?

    Please send the diagnostics for each of your test case, (1) USB to USB and (2) mini displayport.
    Please follow the steps below to get the diagnostics:
    – open spacedesk Driver Console -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – connect the client to reproduce the issue
    – switch Diagnostic Collection OFF
    – click Save All Information button (if a message box appears, just click No to proceed)
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

Viewing 8 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.