Forum Forums spacedesk Discussions update 1.0.67 to 1.0.69 high cpu load after some minutes

Viewing 10 posts - 1 through 10 (of 12 total)
  • Author
    Posts
  • #23397
    el_viejo
    Participant

    after updateing from 1.0.67 to 1.0.69 i have the issue spacedeskService.exe eats constantly between 25% and 45% cpu load while being connected to one spacedesk client. before the update everything was fine. please adivse if you need logs and how to proceed to get them. thank you.

    #23398

    Hi @el_viejo,

    in what way does the high CPU load usually occur? (video streaming/playing a game/etc..).
    Can you also tell us what quality settings do you use in your spacedesk viewer? and maybe send us a screenshot/s of the high CPU load you are encountering?

    For further analysis, please also send us the diagnostic logs of the issue.
    Just follow the steps below:
    – open the spacedesk Driver Console -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – try to connect your viewer app and reproduce the issue
    – switch Diagnostic Collection OFF
    – click Save All Information button
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

    #23405
    el_viejo
    Participant

    hi christian,

    there is no special event triggering the high cpu load. it just occurs by the time while displaying just a static windows desktop. spacedesk viewer quality settings: image quality 100, encoding color depth: high color quality, slow speed (yuv 4.4.4), custom fps rate: 60 fps. the spacedesk server machine is a dual gpu (intel hd graphics 530 + nvidia quadro m4000m). as i am currently back on 1.0.67 i will post screenshot of the high cpu load plus diagnostics data later on.

    #23406

    Hi @el_viejo,

    Thank you for the info.
    We will continue to try to reproduce this issue while waiting for the screenshot and diagnostic logs.
    Looking forward to your feedback.

    #23407
    Sacco_Belmonte
    Participant

    Hi. I also noticed the higher CPU load after the update.


    @el_viejo

    I notice the new version has better latency, my mouse feels a lot less laggy. Is that the case? Could that be related to the high CPU usage?

    Here’s a video of me turning off the spacedesk service. Note how the leftmost core on the third row drop as I turn it off.

    After turning it back on is fine and the CPU usage is super fine.

    #23408
    Sacco_Belmonte
    Participant

    #23411
    jlapp
    Participant

    I am also getting 50% average CPU usage on the new update.

    #23412
    jlapp
    Participant

    Can you please offer older versions of the software, so I can fix this issue?
    edit, found it: https://spacedesk.net/downloads/spacedesk_driver_Win_10_64_v1067_BETA.msi

    #23415

    Hi @sacco_belmonte,

    Do you have a client connected to your server?
    Does this happen even without client connection?

    further analysis, please also send us the diagnostic logs of the issue.
    Just follow the steps below:
    – open the spacedesk Driver Console -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – try to connect your viewer app and reproduce the issue
    – switch Diagnostic Collection OFF
    – click Save All Information button
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

    as for @jlapp,
    What CPU do you use? Intel/AMD?
    Could you also please send the diagnostic logs of the issue on your side? just follow the steps above.

    #23419
    spacedesk Marcel
    Keymaster

    A tentative fix for “High CPU Load” issue was just released on our download page http://www.spacedesk.net Please Update spacedesk Windows Driver to BETA RC 1.0.70 Please let us know if this new version fixes the issue for you.

Viewing 10 posts - 1 through 10 (of 12 total)
  • The topic ‘update 1.0.67 to 1.0.69 high cpu load after some minutes’ is closed to new replies.