Forum Forums spacedesk Discussions Stylus strokes with unwanted cut points

Viewing 7 posts - 1 through 6 (of 6 total)
  • Author
  • #23544

    I’m using a new Boox Tablet X with Android connecting to windows 11, and for the most part, spacedesk works well to use the boox as a monitor for the windows system. One thing that is a little glitchy, though is the stylus data. When I use the stylus, there are breaks in the lines that I try to draw, so that when I drag the stylus from point A to point B, the windows computer seems to think that I might have lifted up the stylus at C, D and E while en route to B. This actually makes even dragging a file icon into a folder rather difficult, since the drag tends to drop the file prematurely. How can I fix it?


    Hi @jedi-cat-3,

    What software are you using to draw? Does this only happen with spacedesk connected?
    Have you tried other editing/drawing software (e.g. Paint)?

    Lastly, could you maybe provide a video clip of the issue?


    Here is a video of me trying to use it. This program is for making concept graphs. In this video I tried to link some words together. I tried to make a diagram of two sentences, first using the touch screen. In the second case, I was trying to do the same action with the stylus At some point, I need to draw an arrow connecting one shape to another. It works fine with the touch screen. But, it fails to keep A single press With the stylus. The software is in this video is CMAP. The tablet is a BOOX Tablet X running Android, and the computer as the video server is a Windows 11 PC.

    As for the problem here–the stylus dropping things unintentionally–I have seen this in other cases, such as when I men to drag a file into another directory using windows explorer. The touchscreen works fine but the stylus doesn’t drag well.


    I couldn’t upload the video so I put it on youtube


    Hi @jedi-cat-3,

    Thank you for providing a Video clip of the Issue.
    also, Please check the Pen option in spacedesk Android viewer under > Input Devices > Pen > and make sure that “Enable Stylus Screen Control” is Enabled.

    and for further Analysis, Could you send us the Diagnostic logs of this Issue?
    Just follow the steps below:
    – open the spacedesk Driver Console -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – try to connect your Android Viewer app and reproduce the issue
    – switch Diagnostic Collection OFF
    – click Save All Information button
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.


    Well, I wasn’t able to figure out how to do the debug mode, and then I got distracted with other stuff, but recently I figured out something that seems noteworthy. I put spacedesk on my yogabook touchscreen laptop and noticed that the glitchy behavior wasn’t present on the laptop, but just upon my PC. The laptop runs Windows 10 and came preinstalled for use with a stylus by lenovo, and the PC is running windows 11 (dell). I use a wacom tablet on the PC, and sometimes even a direct connection has shown that the tablet produces glitch as well, so it must be a setting on windows and probably not a spacedesk fault.


    Hi @jedi-cat-3,

    It appears that this issue may indeed be related to Windows settings, as we cannot reproduce it on any of our devices with different spacedesk configurations. For other users who might encounter this issue in the future, could you please let us know once you’ve found the cause? We will continue investigating this as well and will also update you once the cause is identified.

Viewing 7 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.