Forum Forums spacedesk Discussions Spacedesk Viewer on Linux

Viewing 12 posts - 1 through 11 (of 11 total)
  • Author
  • #1802

    As we had a post on the old forum about Spacedesk on Linux, here it is again 😀

    What does work quite good at the moment:

    Run spacedesk Msi installer for Windows 7 (seems discontinued) -> works quite well
    Spacedesk UWP/Microsoft Store App for Windows 10 -> does not run in Wine.

    Maybe @Spacedesk you could still provide a msi for the Linux Users as on Linux the Windows Client using Wine is ways faster than the Html5 one.


    Hi…can you help me with that? I am new to linux.. i am using zorin os. I tried to install the windows 7 msi(since the win 10 msi wont work) using playonlinux/wine 6.0.1 but the installer just bugs out before completion. I made sure the winecfg has win 7 as the default version but stil it doesn’t work. Thanks!


    Try wine 6.3 in PlayonLinux

    • This reply was modified 2 years, 10 months ago by tuxinator. Reason: missed his mention of PlayonLinux

    I tried 6.3 and also 6.5 but still same issue persists. The installer just bugs out before completion (attached pic). I’ve tried other apps and they install just fine.

    You must be logged in to view attached files.

    Well, you should have read the Title of this Thread 😉 “Spacedesk Viewer on Linux” so only the Viewer works in Wine, the Driver will probably never run in Wine -> as would need to have some really special X-hooks.



    Oh…silly me🤦🏻. Hope we’ll have one for Linux too. This software gets the job done so well, hard to switch.


    It says unable to connect, someone help pls


    Without more details, it will be really difficult to help, please provide more info, for example:

    – What do you try to achieve?
    – How did you try to?
    – What error did you get?



    Not the same person, but also having issues with “unable to connect”.
    Main things I tried were:
    – reinstall wine 6.16
    – tried 6.3 and 6.5
    – tried playonlinux

    All of them lead to the same message when trying to connect with “unable to connect” showing up.
    There are some interesting things that I noticed while doing this:
    – Host server isn’t showing up unless I enter the IP address for the device, whereas the HTML client and all other clients automatically detects the device.
    – The installer finishes a little too fast compared to installing on a standard windows device.
    – When attempting to connect or find a device, from wine logs, there is only one command that is run, wlanenuminterfaces.

    Also as an additional question, are there any output logs for both the installer and client when an error occurs? I’d like to cross reference them with other installation attempts to see what’s wrong.


    Which Version did you try?
    I am currently running 0932 x86_64 and also x32 0932 is working on wine 6.3 using PlayOnLinux, currently i set the Windows-Version to Windows 10 in Controlpanel of Wine. Whenever i had your message in the past, it was network-related like a firewall, also as it does not find your primary machine, i assume a firewall on that Primary Windows Machine blocks it


    @Spacedesk crew, now that Microsoft deprecates UWP Apps, any chance of a Comeback to MSI Packages also for Windows 10/11 ?

    spacedesk Lea

    Hi @tuxinator,
    We will probably switch to Windows App SDK and WinUI 3 for Windows 10/11.
    This will still go through the Microsoft Store.

Viewing 12 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.