Forum Forums spacedesk Discussions Spacedesk Viewer keeps crashing upon run

Viewing 14 posts - 1 through 14 (of 22 total)
  • Author
  • #23856

    Hello, I am using Spacedesk Viewer for a long time, and this morning after running the software the application window appears for a second and closes. I am running on windows 10 Home 22H2. Was uninstalling the software and installing again from the Microsoft store and same effect. Version:
    Any help ?

    • This topic was modified 2 months, 1 week ago by admineon.

    Hi @admineon,

    -Do you have auto-connect enabled in your viewer’s settings?
    -Does the crash occur after you wake your client machine up from suspend (sleep/Hibernate)?
    If you haven’t tried yet, please also try to reboot your client machine.


    Hello Christian,
    Thanks for reply,
    – I think yes. the auto-connect was enabled, but i was uninstalling the app and installing again from Microsoft Store.
    – No, i am shutting down each time the PC and booting it from zero, so it does do reboot.
    – I even installed the server version just to check, and yes, server is working, only client version when starting just showing for a second the window and then it just disappears, no running process in Task lists.
    So weird, just one day it began, wit worked like for a year.
    May be some C++ redistributable needed i don’t know, even there was no Windows updates lately
    I even cleared everything(that has words spacedesk) in Registry after uninstall.
    Maybe there are some logs which are written ?

    • This reply was modified 2 months, 1 week ago by admineon.

    by the way. the HTML version is working ok. so i am using it meanwhile, but you know it is way slower.


    Hi @admineon,

    Just to be clear,
    -Do you enable auto-connect every time you install a new UWP viewer?
    -After booting up the PC, do you then run the viewer and then the viewer will crash?


    Hi Christian,
    – No, after reinstalling i didn’t enabled the auto-connect.
    – Yes. It just showing for microsecond the window and disappears. No Windows error messages, nothing.


    Hi @admineon,

    For further analysis, please send us the dxdiag info of your secondary machine where the crash occurs.
    just run dxdiag.exe on your primary machine, click “Save all information” and send us the output file. (dxdiag.txt)


    Hello Christian,
    Please see attached the log.

    You must be logged in to view attached files.

    Hi @admineon,

    Thank you very much for sending the required file.
    We will continue to investigate and try to reproduce this issue, we will inform you of its progress or if a fix has been made available for this issue.


    Thank you Christian,
    I just tried now to connect via HTLM, yesterday it worked and now this is what i get in Chrome:

    This site can’t provide a secure uses an unsupported protocol.

    Maybe this could help the investigation.
    So, for now even the HTML is not working, looks like something is going on with my windows.
    Good day,


    Hi @admineon,

    Could you please try clearing your browser’s cached files, images, and cookies first before accessing the HTML5 Viewer and then try again


    For information: I am having the same issue.
    Server is a Windows 10 Home PC – server works fine.
    Viewer is a Surface Pro 6 running Windows 10. This was working fine until around 0900hrs (GMT) on Sunday.
    Now loading the programme causes a very brief screen to load and then disappear. Nothing running in the background.

    Running the HTML version also gives the same error as mentioned in a previous post (I’m not clued-up on HTML so decided to abandon this.)

    Installed the viewer on my MotoG50 phone and it works fine. Also tried loading the viewer on my Windows 10 PC which also works fine.

    Cannot roll back to a previous update on the Surface Pro so cannot test.
    Disabled the firewall but same results.

    Hope this helps.


    DXDIAG information attached.

    You must be logged in to view attached files.


    Thank you very much for sending your dxdiag info.
    We were able to reproduce a crash, which may possibly be the same issue you are experiencing. We will continue investigating this problem and will inform you of its progress or if a fix has been made available.

Viewing 14 posts - 1 through 14 (of 22 total)
  • You must be logged in to reply to this topic.