Forum Forums spacedesk Discussions Remote Audio bug

Viewing 16 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #17808
    qstdnx
    Participant

    win10 22H2 (19045.2965)
    BETA RC Version 1.0.67 (Expiry: Dec 31, 2023)
    android:0.91.8

    My screen with speakers use hdmi to connect to my computer. Turn on the remote audio with a deskspace connection on the tablet, Everything works normally. When I disconnect, my screen speaker will not be recognized and can only be restored by rebooting the computer. Disconnecting the HDMI, reconnecting and rebooting the screen are useless.

    #17809
    spacedesk Lea
    Keymaster

    Hi @qstdnx,

    Please check in Windows Settings -> System -> Sound settings, if the output/speaker device is set to correct speaker after disconnecting the spacedesk (with remote audio).
    And maybe try switching the spacedesk OFF-ON via spacedesk Driver Console, instead of reboot.

    #17814
    qstdnx
    Participant

    @spacedesk Lea
    Thank you for your patient reply.
    When the speaker of the screen with the HDMI interface is not recognized, the speaker of the screen is not displayed in the Sound setting. I’ve tried to switch the spacedesk OFF-ON too, and it won’t make the device to be re-recognized.
    There was the same problem in the previous version, and I found a solution. Before I disconnect, I let the computer sleep, and then disconnect the computer after sleep, so that the device will be recognized when I wake up the computer. If the spacedesk is disconnected while the computer going to sleep, the speakers on the screen will still not be recognized after waking up the computer.
    But in the new version of spacedesk, this method has failed. The last version of spacedesk I installed was 0.9.76
    I hope it will help you solve this bug. Please let me know if you need more information.

    • This reply was modified 11 months, 2 weeks ago by qstdnx.
    #17847
    spacedesk Lea
    Keymaster

    Hi @qstdnx,
    Thanks for the info.
    We are currently trying to reproduce this issue on our side.
    We are using HDMI monitor with speaker but so far it’s working properly on our side.

    For further analysis, could you please send us the diagnostic info of your primary machine?
    With your HDMI monitor speaker working properly, please open the spacedesk Driver Console -> Diagnostics, then click the “Save All Information” button, if message box appear just click “No” to proceed.
    FYI: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

    #17895
    qstdnx
    Participant

    Why I can’t see my reply.

    #17899
    qstdnx
    Participant

    I’m very sorry that I didn’t test it clearly when I gave you feedback, so you can’t reproduce it.

    • This reply was modified 11 months, 1 week ago by qstdnx.
    • This reply was modified 11 months, 1 week ago by qstdnx.
    • This reply was modified 11 months, 1 week ago by qstdnx.
    #17903
    qstdnx
    Participant

    https://pan.huang1111.cn/s/jl9oUy

    Attachments:
    You must be logged in to view attached files.
    #17905
    qstdnx
    Participant

    I don’t know why I can’t send out what’s said in the picture.(눈 눈)

    #17894
    qstdnx
    Participant

    @spacedesk Lea
    I’m very sorry that I didn’t test it clearly when I gave you feedback, so you can’t reproduce it.
    After testing, I found that everything was fine when I used both the HDMI screen (hereinafter called S1) and the Android tablet installed spacedesk (hereinafter called S2). The operation of bug reproduction is as follows:
    After the S2 is connected to the computer, in multi-monitor setting(Windows Settings→System→screen), set S1 to disconnect, and only use S2 as the screen. In this case, if the spacedesk is disconnected, S1’s speakers will not be recognized. This is how I usually use spacedesk, so I’ve been obsessed with this bug.
    the same bug occurs when the HDMI cable is unplugged and then connected.
    Please find attached a copy of the file you requested in following link.
    https://pan.huang1111.cn/s/jl9oUy
    Because the file exceeds the forum file size limit:(
    Thank you again for your reply. Please let me know if you need more information.

    #17896
    qstdnx
    Participant

    @spacedesk Lea
    I’m very sorry that I didn’t test it clearly when I gave you feedback, so you can’t reproduce it.
    After testing, I found that everything was fine when I used both the HDMI screen (hereinafter called S1) and the Android tablet installed spacedesk (hereinafter called S2). The operation of bug reproduction is as follows:
    After the S2 is connected to the computer, in multi-monitor setting(Windows Settings→System→screen), set S1 to disconnect, and only use S2 as the screen. In this case, if the spacedesk is disconnected, S1’s speakers will not be recognized. This is how I usually use spacedesk, so I’ve been obsessed with this bug.
    the same bug occurs when the HDMI cable is unplugged and then connected.
    Please find attached a copy of the file you requested in following link.Because the file exceeds the forum file size limit:(
    https://pan.huang1111.cn/s/jl9oUy

    Thank you again for your reply. Please let me know if you need more information.

    #17897
    qstdnx
    Participant

    @spacedesk Lea
    I’m very sorry that I didn’t test it clearly when I gave you feedback, so you can’t reproduce it.
    After testing, I found that everything was fine when I used both the HDMI screen (hereinafter called S1) and the Android tablet installed spacedesk (hereinafter called S2). The operation of bug reproduction is as follows:
    After the S2 is connected to the computer, in multi-monitor setting(Windows Settings→System→screen), set S1 to disconnect, and only use S2 as the screen. In this case, if the spacedesk is disconnected, S1’s speakers will not be recognized. This is how I usually use spacedesk, so I’ve been obsessed with this bug.
    the same bug occurs when the HDMI cable is unplugged and then connected.

    #17898
    qstdnx
    Participant

    @spacedesk Lea
    I’m very sorry that I didn’t test it clearly when I gave you feedback, so you can’t reproduce it.
    After testing, I found that everything was fine when I used both the HDMI screen (hereinafter called S1) and the Android tablet installed spacedesk (hereinafter called S2). The operation of bug reproduction is as follows:
    After the S2 is connected to the computer, in multi-monitor setting(Windows Settings→System→screen), set S1 to disconnect, and only use S2 as the screen. In this case, if the spacedesk is disconnected, S1’s speakers will not be recognized. This is how I usually use spacedesk, so I’ve been obsessed with this bug.
    the same bug occurs when the HDMI cable is unplugged and then connected.
    Please find attached a copy of the file you requested in following link.
    https://pan.huang1111.cn/s/jl9oUy
    Because the file exceeds the forum file size limit:(
    Thank you again for your reply. Please let me know if you need more information.

    #17927
    spacedesk Lea
    Keymaster

    Hi @qstdnx,
    Thanks for detailed info.
    So it also happens even with simple unplug-plug of your HDMI monitor, even without spacedesk involved, correct?
    I think your Windows PC cannot detect the HDMI monitor’s speaker immediately once you unplug and replug it.

    When it happens, can you please try to open your Device Manager (just run “devmgmt.msc”), click the computer name in the tree view, then click the Action tab -> Scan for hardware changes then check if it can now detect the HDMI monitor speaker device in the Windows Sound Settings.

    #17936
    qstdnx
    Participant

    @spacedesk Lea
    Thank you again for your reply.
    According to your method, my computer still cannot re-recognize the S1 speaker. I still can only recover by rebooting.
    As long as my computer is not connected to S2, even if I disconnect S1, the computer will be able to recognize S1 speakers after reconnecting. I used my phone to install spacedesk for testing, and the same situation occurred. As long as I didn’t use the spacedesk screen, unplugged or disconnected S1 will without causing the problem of not recognizing the speakers.
    By the way, did you reproduce the same bug?

    • This reply was modified 11 months, 1 week ago by qstdnx.
    #17948
    spacedesk Lea
    Keymaster

    Hi @qstdnx,
    We tried to reproduce again the issue on our side on different machines, but we still cannot reproduce it.

    • This reply was modified 11 months, 1 week ago by spacedesk Lea.
    #17950
    qstdnx
    Participant

    @qstdnx
    Well, if you can’t reproduce it, maybe the problem lies in my screen or system.

Viewing 16 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.