Forum Forums spacedesk Discussions Native USB connection does NOT work but USB Tethering DOES work

Viewing 8 posts - 1 through 7 (of 7 total)
  • Author
  • #23742

    Thank you for your answer.
    But I still don’t know what’s wrong. I tested the USB connection again and it didn’t work. It turned out that I managed to connect via a mobile network.
    The network is not loaded and the router is 1 m away from the tablet/smartphone.
    Unfortunately, I don’t have a WiFi card on my PC and I can’t use WiFi direct.
    The PC connects to the router via cable and the smartphone via WiFi, so far there have been no problems.

    spacedesk Marcel

    Thank you very much for previously sending in all your logs. We can see that spacedesk native USB connection is failing indeed with an unspecified error. It is very strange to see USB Tethering work while our native USB connection does not work. Does this happen on both of your Android devices? On your Redmi Note 8 Pro and your Prestigio MultiPad. Could you maybe also try a different cable? We never had any report of such a problem. If anyone else experiences a similar problem, please also reply to this thread.



    Apparently I have a similar problem. I am running my Samsung Note 3 SM-N9005 hlte on custom rom (Lineage OS 18.1). The Local Area Network option works but not the USB connection. I am certain that it was connected on USB because the watermark of free license popped up on the client end. However all it showed was just black screen, I enabled touch screen and duplicate display and I can able to pause/unpause media on the client end, however the was no picture shown. The USB connection on SpaceDesk driver console dropped out a minute later but the client side didn’t show it was disconnected.

    I’ve tried reinstalling the android driver, reinstalling spacedesk, enable and disable USB debugging, tried other USB cable. Nothing works. However, I used another two of my android devices, one is running a custom rom as well and the other is not, both of them work.


    Hi @kyransparda,
    So you tried two Android devices and Native USB works on them..
    Could you please try the following:
    -restart your Android device
    -clear spacedesk cache/data in your phone app settings


    Yes, I have reinstalled the Spacedesk app for assurance. However only 2 out of 3 of my android devices work on Native USB:

    1. Redmi K20 Pro on custom ROM (works on both LAN & native USB)
    2. Huawei Mate 10 Pro on stock ROM (works on both LAN & native USB)
    3. Samsung Galaxy Note 3 hlte on custom ROM (works only on LAN but not native USB)

    The Samsung Galaxy Note 3 seemed to have connected to the server as the touch was responsive on duplicate screen. However only black screen was shown the client. I have reinstalled Samsung USB driver, readjusted the resolution and used new USB cable. I still couldn’t get any picture to show on client. The connection seemed to only lasts for about 1 min then abruptly dropped off, however the client side doesn’t seem to show it was disconnected. Only 0 connections were shown on the spacedesk driver console.


    Hi @kyransparda,
    For further investigation, could you please send us the Diagnostic logs of this Issue?
    Just follow the steps below:
    – open spacedesk Driver Console -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – reproduce the blackscreen issue using USB connection.
    – switch Diagnostic Collection OFF
    – click Save All Information button (if a message box appears, just click No to proceed)
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.



    Here’s the diagnostic log with the black screen issue reproduced.


    You must be logged in to view attached files.

    Hi @kyransparda,
    thank you very much for sending the required files.
    we are now analyzing the traces you provided will get back to you as soon as possible.

Viewing 8 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.