Forum Forums spacedesk Discussions Low Bandwidth Issue

Viewing 3 posts - 1 through 2 (of 2 total)
  • Author
  • #18560

    I apologize if this is posted in the wrong area. I can’t seem to find how to post a new topic.

    Overall the software works great when connected to a single machine, I appreciate the USB direct connect feature. My current problem occurs when I use 2 terminals and the MS Mouse Without Borders program as a KVM switch. I have 2 machines hooked up. One of the machines is using SpaceDesk viewer wirelessly. I can’t direct connect it because it disables my 2 external drives I have hooked up to the computer. Spacedesk works good for an hour or two, but then starts to lag. I will discounted the Spacedesk connection and everything returns to normal. My wifi connection is an eeero6+. I have tried other connections and this happens also on them.

    Any help would be appreciated – let me know if I can provide any other informaton.


    Ensure that your wireless network is stable and providing a strong and consistent signal. You can try rebooting your router or repositioning it to improve signal strength. Make sure that you have the latest drivers and software updates installed for your wireless network adapter, graphics card, and any other relevant hardware. Outdated drivers can sometimes cause compatibility issues. Adjust the wireless network settings on your router to prioritize performance. You can try disabling any unnecessary features like QoS (mybkexperience) or adjusting the channel settings to reduce interference. Close any unnecessary programs and background processes on both machines to free up system resources. This can help improve overall performance.


    Hi @WildcatMike,
    Aside from the suggestions above, there are also a few more things you can try to improve the performance with spacedesk.
    Please try the suggestions in the performance tuning chapter in the user manual:

Viewing 3 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.