Forum Forums spacedesk Discussions iPad Air 5th Gen USB Not Connecting

Viewing 2 posts - 1 through 1 (of 1 total)
  • Author
  • #27179

    I have an iPad Air 5th Gen and tried to connect with a Windows 10 Host using a USB-C cable. The iPad app would never connect.

    All prerequisites were met. The spacedesk driver version is the latest 2.1.20. iTunes was downloaded so that the “Apple Mobile Device Support” Dependency was installed. The “USB Cable iOS” setting is checked. I confirmed the application works using a wireless connection.

    I ended up figuring out how to make it work when I installed a competing product called EasyCanvas. The EasyCanvas installer packages older versions of “Apple Mobile Device Support” as well as the 64 bit version and 32 bit version of “Apple Application Support”. With these installed, the USB connection succeeds and the spacedesk application works as intended.

    In my testing, only the older version of “Apple Mobile Device Support” was necessary to have installed to have the USB connection work successfully. I ended up leaving the two “Apple Application Support” versions installed because I figured it could not hurt.

    The version of “Apple Mobile Device Support” that worked is The version that came packaged with the iTunes installer was

    spacedesk Nicole

    Hi @buddman014,

    thank you for the feedback. We will check this.
    Is this iTunes from the Apple website or Microsoft Store?
    Have you tried to download and install the alternative software app “Apple Devices” from Microsoft Store?

Viewing 2 posts - 1 through 1 (of 1 total)
  • You must be logged in to reply to this topic.