Forum Forums spacedesk Discussions I can no longer connect wirelessly.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #25834
    nag
    Participant

    Hello,
    Thank you for the wonderful app. Thanks to Spacedesk, I’ve had a great experience.
    Suddenly, around 10 p.m. on February 18, 2024, Japan time, I found that while I can still connect via USB with my Android tablet, I’m unable to connect wirelessly.
    I’ve confirmed that there are no issues with the firewall settings of my security software. Even after updating to the latest version and reinstalling the app for the secondary machine, the issue persists.
    Could you please advise on the possible causes and solutions?
    Best regards.

    #25838

    Hi @nag,
    Could you please check the following?
    – double check if both of your primary and secondary machines are connected within the same local area network
    – see if spacedesk or C:\Program Files\datronicsoft\spacedesk\spacedeskService.exe is included in antivirus or firewall’s exception list. this is to allow spacedesk service to establish incoming and outgoing connections
    – If you have VPN (Virtual Private Network) active in your machine, please disable it
    – please make sure your wifi router has client isolation disabled
    – check if your current Network profile in your primary machine is Public, if so, switch it to Private. you can navigate this options by going to Windows Settings -> Internet & Network

    #25849
    nag
    Participant

    Thank you for your response.
    I have checked according to your advice, but I am unable to establish a wireless connection.
    However, I was able to connect wirelessly with my iPad.
    It seems there may be an issue with connecting to Android.
    Could you please provide some advice on how to address this?

    #25853

    Hi @nag,
    Is there an error when you connect to your server wirelessly?
    Do you see your server name/IP on your android viewer?
    if not, please try to manually connect, just open the spacedesk App -> click the + sign -> then enter your server’s IP address.

    #25854
    nag
    Participant

    Hi @Christian,

    I can’t see the server/IP on the Android viewer. Also, even when attempting to connect manually, I couldn’t establish a connection at all.

    #25860

    Hi @nag,
    Have you tried restarting your Android device?

    #25865
    nag
    Participant

    Hi @Christian,
    Restarting the Android device didn’t resolve the issue.

    #25877

    Hi @nag,
    Could you maybe check your LAN/WIFI option which can be seen at the bottom of spacedesk viewer connection page?
    Could you you also make sure again if your primary machine and Android device is connected under the same Wifi network?

    please refer to the attached screenshot for assistance.

    Attachments:
    You must be logged in to view attached files.
    #25882
    nag
    Participant

    Hi Christian,

    I managed to establish a wireless connection after updating the driver of the primary machine to version 2.1.13!
    However, the keyboard connected to the Android device is not responding.
    It does respond when the primary machine and Android device are connected via a wired connection.

    #25883

    Hi @nag,
    We’re glad to hear that it is now working on your side!
    For your keyboard Issue, this is because of the keyboard update in earlier versions for security purposes. During network connection, you are now required to enable the encryption option spacedesk Console for keyboard inputs. You can use the encryption feature when you have an Android commercial or business license.

    If you still wish to use it for free, you must connect your Android device to your Windows 11 laptop using a USB cable, or if you still want to use the keyboard via Wi-Fi, you need to purchase the business license for the Android viewer.

    to summarize:
    Keyboard in USB connection = allowed
    Keyboard in Wi-Fi connection = not allowed without a business license.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.