Forum Forums spacedesk Discussions HTML5 client won’t connect

Viewing 10 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #24481
    Wibbly
    Participant

    The Android client connects fine over USB or Wifi, but when I try to use the HTML5 client it just times out. I have tried on both Android (using Chrome) and a Chromebook. I have checked and the IP address of the server (a PC) is correctly represented in the client. The PC’s firewall has had an entry added when I installed the server.

    Anyone any idea why it won’t connect?

    • This topic was modified 6 months, 2 weeks ago by Wibbly.
    #24485

    Hi @wibbly,

    what did the timeout error say?
    were you able to successfully establish a connection before the time out?
    could you please try clearing your browser’s cached files, images, and cookies first in both your PC and android device before accessing the HTML5 Viewer and then try again.

    #24493
    Wibbly
    Participant

    Error is simply Could not connect. Connection Timeout. Make sure your Server-IP is correct

    #24494

    Hi @wibbly,

    have you tried the suggestions above?
    also, Are you currently connected to a public Wi-Fi network? e.g., a hotel, university, or any other public location.

    #24497
    Wibbly
    Participant

    Sorry, yes, I tried the suggestions. Private Wifi network. But a work laptop as the host. Maybe there are other corporate restrictions/policies in the laptop stopping this working that I’m not aware of.

    #24518

    Hi @wibbly,

    you mentioned that your IP is the same as the one displayed in your server.
    you also mentioned that spacedesk Android viewer were able to establish a proper connection but not with HTML5.
    Could you maybe have multiple network adapters displayed in your server? it is possible that you are using the wrong one for HTML5 viewer.

    to make sure that you are using the same IP address as in the spacedesk Android viewer (which has worked before), you can check the IP displayed in the Android viewer and use it in the HTML5 viewer.

    #24519
    Wibbly
    Participant

    Only one network connection/IP. Which is the same displayed in the server and android client.

    #24520

    Hi @wibbly,

    I see, Have you tried different browsers aside from chrome?

    #24521
    Wibbly
    Participant

    No, but I decided to go back to first principles. I can’t ping the client from the server, but I can with from another device. Looks like there’s a corporate policy on the laptop acting as the server that’s blocking server to client connections over wifi

    #24542

    Hi @wibbly,

    For further analysis, Could you please send us the Diagnostic logs of this Issue?
    Just follow the steps below:
    – open spacedesk Driver Console -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – try to reproduce the issue
    – switch Diagnostic Collection OFF
    – click Save All Information button (if a message box appears, just click No to proceed)
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

Viewing 10 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.