Forum Forums spacedesk Discussions Hover for stylus pen on Android (Photoshop on Windows)

Viewing 6 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #18226
    dsibe
    Participant

    Hello, I am experiencing issues when using Mi Pad 5 with a stylus through SpaceDesk with Windows PC in Photoshop. Although everything works well, I am unable to see the brush preview while hovering the stylus. In contrast, the brush preview is visible when I move the regular PC mouse or touchpad.

    I have created a video to show the problem, which you can watch here: https://youtu.be/VM701cLiuxY.
    I have observed that the brush preview/hover appears only when I start drawing with the stylus, making it impossible to know the cursor’s exact position before beginning to draw (which is makes drawing really hard).

    I would appreciate it if you could advise me whether this functionality is supported in SpaceDesk. If not, are there any plans to add it in the future? Alternatively, could anyone suggest any alternatives that I can use to use hover/brush preview in with the stylus?

    In any case, thank you very much for creating Spacedesk! It is wonderful software and even without the hover mode it is still extremely useful.

    #18238

    Hi @dsibe,

    is this only happening in Photoshop?
    Have you tried using your stylus with other editing/painting software? (e.g. paint)
    Could you also please check if ‘Enable Stylus Screen Control’ is activated in your Android viewer settings?
    Please check if the Pen Pressure is configured on your Photoshop brush settings.
    reference: https://www.computerhope.com/issues/ch002027.htm

    #18248
    dsibe
    Participant

    Hi @spacedesk-christian thank you for your reply!

    I tried other programs and hover does not work anywhere. I believe that this issue is not related to the Photoshop, as I tried MS Paint and Chrome and hover did not work in both programs. Also, yes, I can confirm that ‘Enable Stylus Screen Control’ setting is enabled.

    For example, I tried hovering over a button on the Spacedesk forum with the stylus, and the hover animation did not work. The stylus works correctly (click, draw, drag, etc, all work correctly) except for the hover.

    I recorded a video that shows this issue:

    As you can see, the hover mode works correctly when I use touchpad. At the same time, Paint does not react when I move the stylus and hover over the tablet (while it should). I am sorry for the complicated explanation, it’s just a bit hard to explain the issue, I hope that video will make it more clear.

    Could you please tell me if there is anything that I could do to make the hover work with the stylus? I would be glad for any help.

    Thank you for your time.

    #18249

    Hi @dsibe,

    Thank you very much for providing a sample video of the issue.
    We tried reproducing the same issue you are encountering; however, it seems to be working perfectly fine on our side. The cursor/brush preview follows the stylus pen whenever we try to hover it anywhere on the screen.

    Could you please try disabling the “Enable Touch Screen Control” option in your Android viewer settings and see if that resolves the issue?

    #24002
    MeroFabio
    Participant

    Hello @spacedesk-christian

    Not the owner of the post, but I have the same issue as him. I’ve tried disabling the “Enable Touch Screen Control” option but the behavior still persists.

    #24018

    Hi @merofabio,

    We have now reproduced the same behavior you are experiencing. Unfortunately, as of now, this is an expected behavior with spacedesk. You won’t be able to use the actual mouse pointer as a hover pointer with your stylus. If you are using an active stylus (e.g. SPen), we recommend checking its pen settings to see if there is an option like ‘Hover pointer’ or ‘Show pointer when hovering’, if there is, please enable it.

Viewing 6 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.