Forum Forums spacedesk Discussions Can’t connect my IPAD PRO

Viewing 4 posts - 1 through 3 (of 3 total)
  • Author
  • #24445

    I’m trying to connect my work Windows laptop to my iPad Pro 11 but it’s not working.

    In the Network Adapters settings on my work laptop, I can only see the virtual IP address. When I go into the WiFi settings, I find the real IP address for my laptop and input it on my iPad, but it doesn’t show up in the list of available devices on my iPad. It just says “IP validation progress..”, then it failed.

    Even when I enter the physical IP address of my laptop, it still fails to connect. I’m guessing there might be some settings on my work laptop that are preventing the connection, but I’m not sure.

    Do you have any suggestions on how I can get my iPad to successfully connect to and access my work laptop? Some guidance would really help me out since I’m stumped on what to try next.


    Hi @wenxin,
    is this a freshly installed iOS viewer?
    Have you made sure to click “allow” on a prompt that says “spacedesk would like to find and connect devices…” right after you installed it?

    aside from that, please check the following:
    1. Check your WiFi router settings if it has client isolation enabled.
    (This setting prevents direct communication between connected devices/computers.)
    2. Do you have VPN (Virtual Private Network) active? If yes, please disable it.
    3. Are you using any third party antivirus/firewall? if yes, Please add spacedesk in the exception list or ‘Allow List’
    4. Check on your iOS Viewer Settings -> Privacy -> Local Network, if spacedesk is on the list and enabled?
    5. Is your primary machine and iPad device connected to the same local area network?
    6. On your primary machine, please try to set your current Network Profile to “Private” via Windows Settings -> Network & Internet -> Properties.


    Same problem with latest versions. I tried add the IP manually and it stucks on ‘IP Validation in progess’.

    The wierd thing is that I tried using the html5 viewer on the same iPad Pro and it works!

    I have tried turning on local network for the viewer app and rebooting the device, but it still not worked.


    Hi @zjsheep,
    Have you tried the suggestions above?
    Could you please try to reinstall the spacedesk iOS viewer app?
    Maybe you could also check your Ipad’s settings -> privacy -> Local Network -> then make sure to enable the local network for spacedesk

Viewing 4 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.