Forum Forums spacedesk Discussions Space desk connects and works fine but then days later won’t find server Reply To: Space desk connects and works fine but then days later won’t find server


Did you do these on both android viewer app and spacedesk Driver on Windows 10?

Yes, multiple times

Did you already tried restarting the spacedeskService on services.msc on Windows 10?

No need to, after the first 3 times this happened I decided not to start it with windows just in case that was the issue. So I only start that service when I need it now.

However I will try it again

Do you have third party firewall software on your primary machine and/or android device?
Do you maybe have VPN (Virtual Private Network) active

No to all.

Could you please also try to disable the Settings -> Connection -> Automatic Server Discovery, then try to enter the IP address manually?

Have tried manual entering twice before, every time it connects but there is a 30-60+ second lag between what happens and when it’s drawn on screen, tested with “identity” in display settings for reliable testing

What is the current network connection on your Windows 10 primary machine? Wired or Wireless?

Wired. Gigabit, main line connection to router.

It works fine when it’s working, and it works for a few days (turning off and on ofcorse, not one long run) but then randomly just decides not to detect the server (yes it’s up) that it’s been working fine on.

Only thing that makes it work again is a router reset.