Forum Foren spacedesk Discussions Viewer finds connection but on wrong IP address when Tailscale is enabled

Ansicht von 3 Beiträgen - 1 bis 2 (von insgesamt 2)
  • Autor
    Beiträge
  • #24254
    inertia
    Teilnehmer

    I am the latest 1.0.75 version installed using the Windows 0.0.30 viewer on the client machine.

    The viewer correctly identifies the server hostname but shows a green connection available on another IP address than the host in the same subnet. Manually adding the correct IP does not fix it.

    I am using the local IP address on the same subnet as the router and not trying to connect via the Tailscale virtual network.

    The ip of my server is 192.168.0.150 and the viewer is finding a connectable client on 192.168.0.14 (which is another computer that doesn’t have the Spacedesk server installed but does have tailscale). Weirdly it comes up green. If I disconnect tailscale it shows both IPs but connects normally on 192.168.0.150.

    • Dieses Thema wurde geändert vor 6 Monaten von inertia.
    #24255
    inertia
    Teilnehmer

    Update – it only exhibits this problem when the server is running on Tailscale. If the client has the Tailscale network running, it still finds the correct IP.

    #26378
    inertia
    Teilnehmer

    If anyone else has the same problem all I had to do was manually input the server’s Tailscle IP address.

    It would be good if you can choose which adapter the server binds too as it doesn’t allow me to manually enter the correct local IP address which would bypass Tailscale.

    Attachments:
    You must be logged in to view attached files.
Ansicht von 3 Beiträgen - 1 bis 2 (von insgesamt 2)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.