Forum Foren spacedesk Discussions Broken aspect ratio/rotation

Ansicht von 14 Beiträgen - 1 bis 13 (von insgesamt 13)
  • Autor
    Beiträge
  • #24589
    robochemist
    Teilnehmer

    I have downloaded the Spacedesk application from the Microsoft Store onto a spare RCA W101v2 2-in-1 Windows tablet. It seems like the aspect ratio or rotation is broken because the output onto the tablet is always stretched in the wrong ways. Setting the tablet’s display to landscape in the host’s Windows settings turns it sideways (portrait) on the tablet and squishes it the other way. Then, setting the tablet’s *OS orientation* to portrait after that, shows the desktop correctly with gigantic black bars on top and bottom.

    When I took the screenshot, it had a portrait orientation, so I squished it to look like the output I saw on the display. The screenshot of just the settings is the configuration: Portrait host output, landscape tablet OS setting, native resolution on Spacedesk, and no other configuration. I have already tried resetting the Spacedesk settings.

    Everything worked fine with the Windows 7 download from this website. This issue only exists on the application I got from the Microsoft store.

    Edit: To clarify, the pictured settings window is the same exact one between both screenshots, just taken on different displays. (no settings were changed between when I took the first and second one)

    • Dieses Thema wurde geändert vor 7 Monaten, 1 Woche von robochemist.
    Attachments:
    You must be logged in to view attached files.
    #24595
    spacedesk Christian
    Administrator

    Hi @robochemist,

    Thank you very much for providing information regarding your observation.
    we are currently trying to reproduce the incorrect rotation issue of your Windows 10 viewer but so far, we haven’t seen any behavior like this on our side.
    we will continue checking it.
    as for the stretched display, could you try to enable „Custom resolution“ in the viewer’s settings? From here, choose a resolution that fits the aspect ratio of your main screen. Upon connecting, select the new resolution on the Windows Display settings.

    #24614
    robochemist
    Teilnehmer

    Yes. I think it may have something to do with the tablet itself and how the graphics driver/orientation works. Whenever I set a custom resolution like 800×600 in spacedesk, the values come out flipped on my Windows host machine (as 600×800 for example). So, I wanted to flip the values on the client’s side but had to scale it down to fit within the 800-pixel height limit. By scaling down the native resolution (1280×800) to 800×500, and then pre-flipping the values in spacedesk to 500×800, (hoping they will un-flip to be landscape) the image just comes out even more squished.

    (Possibly unrelated but maybe not) when the tablet boots up into windows, the loading animation circle is turned sideways and placed to the right of the RCA logo. I’m guessing this is because, on the hardware level, the default orientation is in portrait mode. the logo is turned 90 degrees just to look nice. example: https://youtu.be/s9QM2BgJv74?t=236

    #24617
    goodman@msu.edu
    Teilnehmer

    I think my problem is similar. I accidentally found a solution, and then on next restart, it was gone again, and I haven’t been able to get it working correctly … the former post was „touchscreen inop…“ and Christian responded. Incidentally, all of this works fine on an Android tablet with the Android client.
    Running the client from the MS Store, although I also tried the Win7 version at Spacedesk’s suggestion.
    I’m trying to use the TDS GTN 750Xi FMS with MSFS 2020, and it won’t allow me to use the touchscreen on my Surface tablet … that is, I can make the touchscreen active („take control“), but when I poke, the buttons triggered are not the buttons being displayed… i.e., the touchscreen’s view of what’s on the screen doesn’t agree with what’s displayed. Here’s what I’m learning:
    1) I am testing WITHOUT STARTING MSFS at all, with the TDS GEN 750Xi in „Standalone“ mode, to try to eliminate confounding factors.
    2) The first pic below shows that the main (server) PC (in Win 11) has the „portrait flipped“ selected as the tablet orientation (screen 4 to the PC).
    3) On the tablet, in settings, the selected orientation is „portrait“, as shown in second pic.
    4) Next pic shows that the „extended window“ as seen on the tablet is SIDEWAYS, so some piece of software has rotated the view so the aspect ratio on the tablet is close to that on the main screens. But of course, that means it is turned 90 degrees.
    5) The next pic shows what happens when the TDS GTN 750Xi is dragged onto the tablet… it is rotated just as the background screen was, so it sideways and not really usable. However, when the PC’s mouse is used, the buttons work fine, but after „take control“ on the tablet, the buttons shown still do not respond to touches (at least not properly, although the touchscreen is clearly active, because dragging fingers around occasionally triggers responses from the 750Xi.

    I have to do another post to show the remaining pictures, and I hope that will work, because this post will not let me upload more than 4 pictures. BUT what these pictures will show is
    6) If I tell the main PC that screen 4 is in landscape mode, then the picture on the tablet rights itself, and, although squished, allows the mouse to function fine.
    7) When the TDS GTN 750Xi is dragged into THIS view, it displays perfectly, and the mouse works perfectly (see the picture), AND the touchscreen is active (after „take control“), BUT the buttons are in different locations than displayed. That is:

    I believe the touchscreen coordinate system is not being massaged so as to match the displayed screen orientation.

    The disturbing thing is that I know it is possible to find a way to make it work properly, because I did have it working for a few days, until a reboot changed something (I don’t know what), and I haven’t gotten it working in the week since. Any help would thus be MUCH appreciated.

    Attachments:
    You must be logged in to view attached files.
    #24623
    goodman@msu.edu
    Teilnehmer

    Here is the second post.
    What these pictures will show is
    6) If I tell the main PC that screen 4 is in landscape mode, then the picture on the tablet rights itself, and, although squished, allows the mouse to function fine.
    7) When the TDS GTN 750Xi is dragged into THIS view, it displays perfectly, and the mouse works perfectly (see the picture), AND the touchscreen is active (after „take control“), BUT the buttons are in different locations than displayed. That is:

    I believe the touchscreen coordinate system is not being massaged so as to match the displayed screen orientation.

    The disturbing thing is that I know it is possible to find a way to make it work properly, because I did have it working for a few days, until a reboot changed something (I don’t know what), and I haven’t gotten it working in the week since. Any help would thus be MUCH appreciated.

    #24629
    robochemist
    Teilnehmer

    Yes! It seems as if we are having the same problem, and both of us are using Windows tablets too. Coincidence? I think not… (Since I’m not the only one, this eliminates the possibility of hardware-related problems.) Does the Windows 7 version of the software work for you? Because I’m only having issues with the MS Store version. This image shows the same settings window with the same settings as described in my first post.

    • Diese Antwort wurde geändert vor 7 Monaten von robochemist.
    Attachments:
    You must be logged in to view attached files.
    #24636
    spacedesk Christian
    Administrator

    Hi @robochemist, @goodmanmsu-edu
    For the orientation Issue, Thank you for providing further info about this. however, for further investigation, could you maybe provide the exact step-by-step procedure on how to reproduce this issue? just to be sure that we are doing the exact same thing as we are still unable to reproduce it on our side.

    for @goodmanmsu-edu,
    For Touchscreen issue on MSFS (if this is the case for you as well)
    We have a previous spacedesk users that verified that MS Flight Simulator does NOT support/recognize touchscreen input (in general not just in spacedesk).
    And according to that user, it can only recognize mouse input from a remote display.

    We can only suggest either of the following:
    1. Use mouse touch which automatically activates on your second viewer connection.
    Current spacedesk’s touchscreen only supports in first spacedesk display, so on your first viewer app just activate touch screen first, then connect a second viewer app where you can move your flight simulator app and try to send the mouse touch input from there.
    2. Select relative touch input in your viewer app settings (the touch input will behave as mouse pad for your primary machine).

    #24662
    robochemist
    Teilnehmer

    I have tried replying to the last thread with this name (https://forum.spacedesk.net/forums/topic/broken-aspect-ratio-rotation/) but across multiple devices and times of day, it won’t let me reply, so i’m making a new topic.

    Here are the steps in answer to your previous question:
    1. Install SpaceDesk from the MS Store onto a Windows 10 tablet
    2. No configuration on the viewer (default space desk resolution and settings)
    3. Connect to host
    4. Set rotation for the viewer’s display to „Portrait (Flipped)“ in the host desktop’s settings (This is the view shown in my screenshots)

    I think the problem has less to do with the program itself and more about what hardware it’s installed on. It’s probably how Spaceadesk handles rotation/orientation/scaling on Windows TABLETS specifically. I’m not sure how Windows handles this exactly, but my theory is that rotation on tablets is handled differently from desktops, and SpaceDesk doesn’t know how to deal with the tablet’s style of rotation reporting. All the resolutions are correct, the output is just getting rotated and squished around. I’m not a Windows expert but that’s what I think so far…

    #24665
    spacedesk Christian
    Administrator

    Hi @robochemist,
    Thank you very much for providing the steps for this issue:
    we have tried but are still unable to reproduce it on our own windows tablet.

    We just have a few more questions..
    1. for #4, I thought you need to set a custom resolution like 800×600 in the spacedesk viewer which will then AUTOMATICALLY set its orientation to ‚portrait-flip‘ upon connect? –„Whenever I set a custom resolution like 800×600 in spacedesk, the values come out flipped on my Windows host machine“
    2. what is your primary screen’s resolution?
    3. for @goodmanmsu-edu, does your windows tablet has windows10 OS too?
    4. a lot of info has been provided and has been very useful in investigating this issue, but if it is possible, maybe you could also send us a video clip showing the steps and actual result of this issue? this is only optional.

    #24669
    afalout
    Teilnehmer

    Hello

    I have the same problem. I use two Microsoft Surface Pro tablets, and I’m trying to get the server side to be in Landscape and the client in Portrait. The client side works OK in Landscape but I cannot get it to show correct Portrait orientation in any ways I tried – and I tried many. Its almost always flipped in the wrong direction and/or stretched, in every combination you can think of – just not the correct one.

    Server is W11, client W10. Client app is from the MS Store.
    I did not try the W7 client as I did not know it would work on W10. Should I?

    BTW, touch does not work at all on the client.

    Any help is appreciated.

    #24670
    spacedesk Christian
    Administrator

    Hi @afalout,

    -Could you please check in settings > system > display what is the resolution of your server and client display?
    -Yes, win7 viewer also works on windows 10. please try it on your side.
    -For the touch issue: please refer to the suggestions from this topic ( https://forum.spacedesk.net/forums/topic/touchscreen-inop-under-viewor-on-surface-tablet/ )

    #26104
    CM
    Teilnehmer

    Unfortunately, I have exactly the same problem. The second screen is also a touch notebook with a built-in orientation sensor. I am using the Windows store viewer on Windows10.

    I played around with the settings for 2 days and found a workaround that worked for me.

    The problem is indeed that the viewer thinks it is in portrait mode. So, the workaround was to set the client display of the second notebook to portrait mode, then start the Spacedesk Viewer connection, and then set the display settings back to landscape mode.

    I hope this helps some of you here in search of a solution.

    The problem could simply be solved with a „Set orientation“ function in the viewer app.

    #26108
    spacedesk Nicole
    Administrator

    Hi @cm,

    your suggestion is very much appreciated. Thank you!

    #26111
    CM
    Teilnehmer

    I’ve noticed that sometimes after setting back to landscape mode, the scaling of the Spacedesk Viewer remains in portrait mode (but the oriantation now is correct). In this case, simply disconnect and reconnect. Then it worked fine for me again.

    • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von CM.
Ansicht von 14 Beiträgen - 1 bis 13 (von insgesamt 13)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.