Forum Foren spacedesk Discussions Active screen timeout?

Ansicht von 9 Beiträgen - 1 bis 8 (von insgesamt 8)
  • Autor
    Beiträge
  • #23733
    dougw03
    Teilnehmer

    I frequently need to switch PC’s and I minimize my spacedesk viewer app. However, I find that the monitor will disconnect if I leave the viewer minimized for more than a couple minutes or so. Is there a way to adjust the disconnect timeout period on the viewer app? Thanks

    #23738
    spacedesk Christian
    Administrator

    Hi @dougw03,

    Are you using spacedesk Viewer for Windows 10? This is expected behavior for UWP apps, but a workaround can be done by setting the ‚Disconnect Delay‘ in the spacedesk Console to -1. This will not unplug your secondary machine and will resume its connection when the UWP app becomes active again.

    Note: There are two ‚disconnect delay‘ settings in the Console: one in the Control Settings and one for the VideoWall settings. You should choose the one based on your setup (if you’re using a VideoWall or just a normal connection).

    #23746
    dougw03
    Teilnehmer

    Thank you Christian. Indeed I am using the UWP app on Windows 11. I believe I am also using Videowall even though it is unassigned since disconnect delay is grey under control settings. Unfortunately my company’s IT department has software on my machine which prevents me from disabling videowall. I’ll report back if things do not work.

    #23748
    dougw03
    Teilnehmer

    I have set Videowall disconnect delay to -1 and my monitor is unassigned under videowall. If I assign the monitor then the screen has issues. The UWP app still disconnects if I don’t have the app open and maximized. Do I need to have my PC assigned to a videowall for the timeout settings to take effect? I cannot disable videowall due to the aforementioned IT software.

    #23749
    spacedesk Christian
    Administrator

    Hi @dougw03,

    The Disconnect Delay settings should work even without assigning the monitor under the videowall. It will disconnect its current connection, which can be observed in the console, but it will not unplug from your primary machine and should resume its connection immediately upon UWP return.

    Please check the secondary machine in Windows Settings > System > Display and observe if it still unplugs.

    Could you also provide us with the following information:
    -What issue are you encountering when you assign it to the videowall?
    -Is it possible for you tell us more about this software that prevents you from disabling the videowall mode?

    #23801
    dougw03
    Teilnehmer

    Hi Christian, every time I tried to reply to your post it would never go through so I took a screenshot of my text and attached here.

    • Diese Antwort wurde geändert vor 6 Monaten, 3 Wochen von dougw03.
    Attachments:
    You must be logged in to view attached files.
    #23811
    spacedesk Christian
    Administrator

    Hi @dougw03,

    Re #1 – Are you using a custom resolution in your UWP viewer?
    what resolution are you using?
    could you please try assigning your viewer to a videowall, then go to ‚Videowall Client Settings‘ > Click ‚Float wall preview‘ > check the resolution indicated in the floating wall window > use that resolution instead of your Viewer monitor’s resolution.
    note: you have to hit the enter key per textbox (Width/Height) for the measurement to apply.

    Could you perhaps check the following as well?
    -Make sure that your UWP is updated to the latest version. We recently released a new version in the MS Store.
    -Also, your spacedesk Driver to v1.0.73
    BTW: Just to be clear, does your UWP viewer fail to reconnect when put to maximize?

    Re #2 – Thank you for providing information about this software, we will conduct an investigation about this problem.
    On the other hand, spacedesk Videowall is already disabled by default upon installation.

    #23816
    dougw03
    Teilnehmer

    Hi Christian,

    Re #1, I am using the default resolution (no custom) for surface pro 8 (2880×1920). I tried your suggestion but it didn’t seem to work. My viewer and server are both the latest version updated today. See attached screenshot of both monitor.

    Regarding the disconnect, I forgot to add more details because my post kept getting rejected. It seems to be working fairly consistently now. I’d say 1 out of every 10 tries I will re-maximize the UWP viewer and it will open for a split second then the app will close entirely. I cannot seem to pinpoint exactly when this happens but I will report back if it starts happening more frequently. I also just updated the viewer so maybe this issue will be fixed now.

    • Diese Antwort wurde geändert vor 6 Monaten, 3 Wochen von dougw03.
    Attachments:
    You must be logged in to view attached files.
    #23822
    spacedesk Christian
    Administrator

    Hi @dougw03,

    Thank you very much for sending additional information,
    Re #1, Could you try changing your Wall dimension to 2880×1920, then do the same resolution to your Videowall Client settings.
    For assistance, please refer to the attached Screenshots.
    note: you have to hit the enter key per textbox (Width/Height) for the measurement to apply

    Could you also check again with the -1 disconnect delay? you need to hit the enter as well for this setting to apply

    FYI: We just released a new spacedesk UWP viewer on the MS Store. please update your viewer and use it to test the above suggestions.

    Attachments:
    You must be logged in to view attached files.
Ansicht von 9 Beiträgen - 1 bis 8 (von insgesamt 8)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.